Teletype keyboard issues


#21

Yes, this is the one I was posting about above. I bought this one - but note that there are options when you come to buy that allow you to choose switch type and whether there is LED lights or not. At least, there was on the amazon UK site. Note that there may be more than one listing for the same keyboard from different suppliers. Choose one which is coming from a local supplier (ie on the same continent!)

I opted for no LEDs and Cherry Blue switches. I’m very happy with it.

EDIT: here!


#22

Has anyone tried using a KVM style USB switch to share one keyboard between a computer and Teletype? It would be nice to save some desk space.


#23

Hey folks :wave:

I’m not experiencing exactly what the thread started as, but it seemed close enough to the original thread so I thought I’d keep it alive.

I just got my Teletype yesterday. Loving it, gradually working it into my flow. All works as expected except I cannot figure out the Manually Execute a Script shortcut.

The Teletype Studies page said it should be Win + n, while the key card says it should be Ctrl + n. Neither of these work for me.

Any guidance? It would be such helpful functionality while composing scripts.

Thanks a ton!


#24

yeah, both of those sources need to be updated. would anybody be able to perhaps help with those?

this should have the latest shortcuts (it’s linked from the teletype page): https://monome.org/docs/modular/teletype/manual/#global-key-bindings


#25

I believe that manual launch has been changed to using the function keys in later firmware versions. Check current version of the manual. Teletype studies might be outdated regarding that feature.


#26

I have now, and it works mostly fine. (Audio cuts out on my computer when switching, which was unexpected; I’m using a Firewire audio interface…)

I’d link to the exact switch I bought on Amazon, and warn that it didn’t come with USB A to B cables that are necessary… but apparently it’s gone already.


#27

Thanks! I assume teletype studies is open sourced?


#28

they are indeed!


#29

Have you made sure that there is no system noise associated with dis/connecting hardware?

Additionally I might suspect that a cheap KVM switch could short out the USB port briefly while being toggled. This could open the resettable polyfuse for a brief moment. I don’t feel like this should affect your firewire interface unless your firewire port is protected by the same fuse as the USB.


#30

Windows does play a sound for USB device (dis)connection. That seems unlikely to be the cause though, since turning on my Microbrute (which is connected over USB) after I’ve already got other things going doesn’t seem to matter (except that my DAW won’t recognize it as a MIDI input device that way).

It’s a Logitech keyboard with a driver for fancy lighting stuff, gaming profiles I don’t use etc. so it’s possible something about that is tying up I/O for a couple of seconds.


#31

Hmm… I notice the transport in Maschine actually stops briefly when I flip the switch. But it’s not due to temporarily losing its connection to the Maschine hardware, since I can unplug that without disturbing it and switching the keyboard still does.

It’s also not the “Logitech Gaming Software” driver.

I guess I’ll just have to make sure I don’t switch the keyboard while I’m recording something, and it’s probably okay image


#32

Just ran into the same issue as @robbbiecloset, I’ve submitted a PR to update the relevant study: https://github.com/monome/docs/pull/32

Yay, first day with Teletype, and my first monome related PR!


#33

Beat me to it! :sweat_smile:

I’m sure there will be other opportunities.


#34

:sweat_smile: I found this thread after submitting the PR, low hanging fruit hehe.


#35

anybody already tried to connect a wireless keyboard (the ones with usb dongle)?


#36

try forum search for a bunch more possibly


#37

thanks!
any reason why some work and others not?


#38

Logitech keyboards with a Unifying receiver dongle work well with it. You have to pair it using a computer first, but then you can just plug it into the Teletype USB port afterwards.

I’m using mine with a K780 keyboard which can switch between three devices.


#39

I’m the guy with the Microsoft keyboard. It works great, I have been using it all this time with no trouble.


#40

ok, thanks for the advice, I’ve ordered the Microsoft keyboard, will let you know how it goes:)
best,
pascal