Teletype MIDI IN ops

damn, totally forgot about my nanokontrol2! perfect size for intellijel palette case.

could somebody test MIDI start/stop/continue events? trying to test and getting super frustrated, my machinedrum for some reason is not sending the events, and i can’t reconfigure the nanokontrol - because apparently you have to use the newest windows 10 driver, otherwise it doesn’t recognize it, the only issue is it’s 64 bit and therefore not compatible with korg’s own 32 bit editor :roll_eyes:

I just tried the midi in experimental fw today. My ambitious goals stopped in its tracks, when I found it seems that to handle note on and note off and nothing else, you need two handler scripts. Am I missing something?
High hopes for the future with this awesome addition to the teletype!

I’ve tested the Start, stop and continue messages with Max, it works. I’ve tested with a simple TR.P 1 in the first script, to confirm 250, 251 and 252 are received.

Novation Launchcontrol and Elektron Model Cycles won’t connect to TT .
The Model Cycles is powered externally and the Launchcontrol requires only 60mA and doesn’t seem to cause a failure when connected to TT. But these two devices aren’t recognized unfortunately. I don’t have many other controllers to test with, perhaps the Softstep but it might draw too much power and I’m not sure I can power it externally right now.

Thanks for your work on this project by the way :wink: I should try to power the Blocks externally with Two>One like you’ve suggested. I was trying to avoid too many USB cables around the Eurorack case but if it’s the only way to make it work…


Does the nanoKontrol requires an external power source or can it be connected to the Teletype directly ? If it can, I’ll probably get one, the size is perfect and it’s relatively cheap :slight_smile:

Connects directly to my first-gen green TT, works perfectly without any additional power.
Has a great editor too that works with macos catalina, to my sheer surprise!


Great ! I’ll order one then :slight_smile: Thanks.

1 Like

I did test with my korg sq1 and happy to report that start/stop triggers here (continue not supported by device I guess).

sevillasoft dongle from laptop worked too :pray:

how crazy/cool is triggering tt scrips from norns??!

thank you so much for doing this! was on my wish list for a long time. feels like a door to another universe just opened…


you can assign the same script for both:

MI.$ 1 1; MI.$ 2 1

IF == MI.LE 1: note on
ELSE: note off

cycles - do you have MIDI out enabled? i don’t have cycles but will test with digitone.

surprised about launchcontrol… can somebody try other novation devices?

Yes I do, I double checked that the Model was sending CC and other messages on my computer using Midi Monitor.

yes, I don’t know why some devices aren’t recognized. I’ve just tried with an OP-Lab (the old one) by Teenage Engineering, not recognized either.

1 Like

good to know - thanks for testing!
i’ll see if i can find a controller that would let me reproduce the issue.

do you have ansible by any chance? could you try one of the devices that didn’t work with ansible midi mode?

Erratum: The OP-Lab (this one) seems to work.
I’ve managed to plug the Roli Blocks And a KMI QuNexus at the same time. Both sending midi to TT, pretty cool. It’s powered externally of course.

And the QuNexus can also work plugged directly to TT (with keyboard’s LED set to off)

1 Like

so it worked with one op lab but not the other one?

It’s the same OP-Lab. This device can be a bit buggy, especially when it’s in “midi merge” mode. The second time I plugged it (after a power cycle) it was recognized by Teletype.

1 Like

could you do one more test - what happens if you route cycles MIDI through the op-lab?


Cycles is not recognized by the OP-Lab in USB. The Novation Launchcontrol is not recognized by the OP-Lab either…

QuNexus plugged directly to TT -> OK
Cycles through DIN via Connectivity MIO -> OK
Cycles through DIN via OP-Lab -> OK

Cycles plugged directly to TT via USB -> NO
Cycles plugged to TT through OP-LAb via USB -> NO

Edit : and the Transport from cycles works, via DIN (Via Mio)

1 Like

so judging by the manual, cycles also sends audio via USB. i wonder if that’s the reason it’s not being recognized as a MIDI device. so yeah, you will have to use the minijack MIDI outs as a workaround.

still not sure about the launch control. i thought maybe it’s not class compliant but the documentation says it is. but interesting it’s not recognized by the op-lab.

Yes that’s right but I disabled it before doing the tests, USB only sends Midi now.

I’ve found something else while doing the test with Cycles through MIO (in Din)
TT triggers script 1, in response to CC, Start and stop, even though the init script is MI.$ 5 1
Shouldn’t it filter the CC’s and pass only “Start” ? Same thing from Max.

execute MI.$ 3 in live mode and see what it returns - perhaps CC events got assigned to scirpt 1 previously?

to confirm, yes, it should only trigger an assigned script from the event types it’s associated with, but it’s possible to assign multiple event types to the same script.

it’s more how it reports itself - it’s possible that even with audio disabled it still reports itself as something other than a MIDI device…

1 Like

ah, correct, my bad, sorry… MI.$ 3 returns 1, I didn’t know the previous Init commands remain. I didn’t power cycle TT, only hit F10…

I understand