Teletype related Did my brand new synthrotek power deluxe fry out?

I hope the teletype is ok! :weary:

So I recently bought a second hand teletype and have an ansible on order. For power I bought a customer demo model synthrotek power deluxe from perfect circuit. I bought a brand new synthrotek universal power brick as well.

Today was the first time I put a little box together with the power deluxe and the teletype. I was doing the teletype studies for about two hours when I abruptly lost power. It sounded like the power deluxe shorted out. Now it won’t turn on.

The power brick has a green light on it. It stays lit bright green until it is plugged into the power deluxe and switched on. Then the green light dimly flickers.

Also while writing scripts and using a moog mother32 with patching going on the keyboard would go unresponsive. This happened 2 or 3 times. I had to power cycle and unplug replug the keyboard. After a couple times of doing that I removed all the patch cables and then the keyboard did not drop out but I lost all power about a half hour later.

Bummed as I was having fun with teletype!

I don’t own any of these devices but there are a few standard things to check.
Questions:

  • Are the +12/-12/+5 lights on the power module coming on or not?
  • Have you removed all modules from the power bus and tried it then? Is it behaving the same?
  • Is there a user replaceable fuse either on the power supply module or the power brick? If there is, have you replaced it?

Hi @sandy

No lights on the power module are coming on since power loss. I have removed the teletype from the power module (only module I was using) and still no power. The module has no fuse. The power brick does not look easily openable and I tested the output of the brick with my voltmeter and it is what it should be.

Presently I removed the big “safety” diode from the sythrotek and am getting a reading of .147 with the negative lead on the cathode/positive on the anode, and no reading when reversed. This sounds like it may be low? I am just going off of internet tutorials on testing diodes though so I’m not positive if this a low reading for this particular diode. I’ll have to research some more.