Teletype screen problem

#1

It was two days I didn’t use my teletype, I put it in a new case (a Mantis) and the two lower lines are not readable anymore. I tried putting it in the old case but it’s the same, and it happens even with no i2c devices connected. I tried reflashing the firmware with no improvements. It appears to work perfectly though.
Anyone had this happen? Any solution?
Thanks.
:frowning:

0 Likes

#2

Tagging @tehn here as I’d think he would have your quickest answer. My fingers are crossed for you that the Italian post doesn’t once again come between you and that Teletype.

1 Like

#3

seems the OLED is has a defect. try manipulating the screen’s ribbon cable (it’s orange) while the TT is on and plugged in (but unmounted). you’ll probably see the lines flicker on and off. let me know if it sticks.

otherwise e-mail info@monome.org and i’ll get you a replacement screen

2 Likes

#4

I’ve sent you an email. Thank you :pray:

0 Likes

#5



I didn’t turn on my modular for a month, now all the rest of modules are fine except the TT. The screen is very dim, some of the lines even cannot display.

Does anybody encounter this problem? Is there anything I can try by myself before send to repair?

0 Likes

#6

email info@monome.org

0 Likes