Teletype v1.1 Issue with USB flash drive scene read/write

So still no news about the USB issue of not being able to load/save presets? This silly issue has got me very lazy with the Teletype. Waiting for it to get fixed, I’ve given up writing new scripts.

Has anyone else with a Teletype been able to get a USB memory stick to work with it? I can’t believe only four or five people have tried it, or care about the issue, if we were going to believe the amount of people who have reported it in these threads. That’s why I’m creating this new thread, to keep the issue alive, and to be able to focus on it. Eventually, I would like to go back and make a list (which is not very long) of the amount of people who got their Teletype saving to a USB memory stick or card, and those who have reported it as not working, and what we have been using. But if you are one of them, can you please say so here, to see if we can find a pattern?

I wonder if there is a difference with hardware components in some Teletype’s, though I also assume they should all be the same, from the same production run?

Just an idea, for those living in the States… Would it be possible for you to post to monome the USB stick or card you tried and that didn’t work, to see if it works for tehn? And perhaps tehn could send to that person a USB that works on its Teletype, to see if it works? That should be cheaper than to start sending Teletype’s back to monome (especially from Europe), to test and see what the issue could be. Or if there is no issue with their own supply of USB memory sticks, perhaps to offer selling us one that would work with the Teletype?

i’ve just acquired a pile of random-brand usb sticks to try.

all TT have exactly the same components from the same reels.

please post power supply specs-- though this shouldn’t matter so much given the TT makes its own 5v. but this is really the only possible variability between people’s systems.

i’ll also try to add some debug information on the USB enumeration process, for a “test” firmware.

As per the other thread, I’m having the issue. My power supply is a 4ms Row Power 40. I have Teletype connected to the complete Trilogy, if that matters as well. I’m on 1.1 (not 1.11 or 1.12).

[quote=“trickyflemming, post:3, topic:2802”]
My power supply is a 4ms Row Power 40. I have Teletype connected to the complete Trilogy, if that matters as well. I’m on 1.1 (not 1.11 or 1.12).[/quote]

Interesting. Same here: 4ms Row Power 40, TT connected to the trilogy, and on v1.1. There might be a pattern. I’ll try moving the TT to my other cases, and see what happens, but since it’s such a pain to move it with the trilogy connected…

just tested on my row power 40 with two new sticks:

Lexar 16gb LJDTT16G
SanDisk Cruzer Glide 16GB

both worked perfectly first try-- didn’t even reformat them (they are FAT32)


thanks for the PS specs. can you reiterate which USB drives you’ve tried? i know some of you got the same kingston DTSE9 i suggested, right?

Among the ones I’ve tried, as far as I remember: Verbatim 4GB and 8GB, Ativa 4GB, a very old (more than seven years old) USB memory stick… For more detailed specs, I’ll have to find them on the Internet. I also tried with a cheap SD card reader and a 4GB SD card… All formatted to FAT32, using Mac and PC… Though the very first time I might have tried the USB memory sticks without formatting.

and just to confirm the issue-- TT boots straight to prompt without going through the WRITE/READ screen, correct?

Correct. But, is there a Read/Write screen? TT just boots as normal, and when looking into the USB memory stick (on a computer), there is nothing.

Yes, I’ve never seen the Read/Write screen (wasn’t even aware of its existence).

I’ve used the Kingston stick that you recommended (the USB 2.0 version), a 16GB HP stick, and a random 512MB KRK USB stick that came with my monitors.

try this build. it waits longer to enum the disk.

tt-160328-delay20.zip (76.2 KB)

That works!

This time it did show Writing… Reading… And when I checked on the computer, all the scenes are there. Great!

Thanks!

can you tell me if this one works? hoping to minimize that delay.

tt-160328-delay15.zip (76.2 KB)

OK, will try, but I didn’t feel it was taking too much time. I do, however, seem to have an issue, but it might not be related: that update deleted all scenes, so I tried to put back scenes 1 to 7, as downloaded before, but strangely enough scenes 1, 3, 5 and 7 seem to fail to read. They remain empty. The other ones work fine.

The second version, delay15, also works. And now I understand why you might want to make the delay shorter: it’s ok when writing and reading scenes from a USB memory stick, but it can feel a bit long when just powering TT in general.
I’m still having issues with TT not being able to read scenes 1, 3, 5 and 7. I need to do some further testing, download the scenes again, change their order and entering one of my own, and see what happens.
Also, curiously enough, TT might not have a sense of time, not know what day it is, but all empty scenes get saved as 1 Jan 1970 at 1:00 AM.

Very quickly, I renamed some scenes and I can confirm the problem are not the scenes, but TT failing to read scenes 1, 3, 5, 7, and I assume all odd scenes.

they are being written just fine?

try this. added delays in between file reads.

it’s like the USB is just weirdly slower?

tt-160328-delay15-slowread50.zip (76.2 KB)

That slowread50 didn’t make a difference, apart from the Read progress status showing a bit slower, similar to what Write takes. Before it was quite fast, compared to what Write took. But still fails to read scenes 1, 3, 5 and 7. But has no problems writing all scenes.
I have also tried a few USB memory sticks. Write/Read doesn’t work with a 4GB Ativa, but still works fine with my oldest USB memory stick (2GB) and it’s also fine with a 8GB Verbatim. The only issue remains not being able to read scenes 1, 3, 5, 7…

ok-- i’ll look into the odd numbered filenames. glad we’re getting somewhere!

Yes, we’re definitively getting somewhere. :relaxed: It makes such a difference to my workflow to be able to back up and load scenes. Even if my TT is currently failing to read some scenes, I can work around that. Many thanks for your help.