Teletype v1.1

Teletype 1.1 is ready for all. Firmware update includes all factory scenes from v1.0.

Upgrade instructions: http://monome.org/docs/modular/update

New feature guide (see addendum): http://monome.org/docs/modular/teletype

All v1.0 scenes available in text format: http://monome.org/docs/modular/teletype/scenes-1.0

5 Likes

how are people doing with this new upgrade?

1 Like

loving it


haven’t had enough free time to transcribe/backup all my patches… but i am looking forward to trying out the numeric keypad feature!

haven’t had a chance yet (working on orca update)
was wondering if anybody tried metasequencing like SCRIPT P.NEXT already

2 Likes

all good here but been sucked by some work.

So if i understand that right…if you fill a pattern with 1-8s and get crazy with scripting it will patch itself

nice one

I started messing with script op but not combining variables or the tracker

yep, exactly. should be interesting once you have the scripts messing with the pattern itself.

I’m trying to get Teletype to back up the current scenes into a USB memory stick, but not having much luck so far. I’ve been trying with a 4GB Ativa and a 8GB Verbatim, both formatted on a Mac, as MS-DOS (FAT 32). I insert the memory stick, power the module and when I check, there is nothing written in the memory stick. Am I missing something, or do I need to find the ‘right’ memory stick for it?

ugh-- i have no idea. it’s very straightforward-- power it up with the stick in there, with fat32 format.

i’m not sure what to suggest except try reformatting again, and trying a different flash drive. like SD cards, flash drives (and removable media in general) seem to be a really huge pain.

If printed docs work better for you (and you can stand the guilt of killing trees), here are the new TT1.1 commands formatted as a PDF for printout:
151230 TT 1.1 addendum.pdf (49.4 KB)

3 Likes

Loving the new firmware. However, I also cannot load/save presets to a flash drive. I’ve tried several different ones and am certain they were all FAT32. If you have a lot of scenes, I would be very wary of upgrading.

Same here, despite trying many different USB memory sticks, formatted as FAT32 in Mac or PC. Can the lucky ones who got a memory stick or card recognised by their Teletype post the specifics (brand, size, formatting), so we, the unlucky ones, can try to get one of the same ones and see what happens? I would like to try a more scientific approach, instead of keep getting memory sticks to see if finally I got a lucky one.

i would avoid high-capacity sticks (>= 4gb) if at all possible… these things have their own little microcontroller, and they play stupid tricks. i have been using a 2GB sd card for years now with no trouble. (it shipped with my nintendo Wii, hah.)

and yes, i agree: it is silly that the pace of technological improvement outstrips our ability to use that technology… in a DIY-friendly capacity.

if anyone knows of an open-source, ANSI-C library that can deal with bigger FAT32 drives… i am all ears.

EDIT: pff, sorry, i realize that you are talking about mass-storage usb devices on the host port, and using the atmel framework’s MSC and FAT classes. so the answer, if any, lies there…

… and indeed, looks like this is the same old FAT service header from 2009. this guy doesn’t like high capacity devices either. [ https://github.com/tehn/mod/blob/master/xdk-asf-3.17.0/avr32/services/fs/fat/fat.h#L169 ]

1 Like

The last memory stick I tried was a 2 GB one, that I had for more than 7 years, formatted as FAT32. So I’m giving up hope with memory sticks. I’ll try to memory cards. If anyone can post the specifics of their working memory stick or card, that would be great. But not buying a second hand wii on ebay just for the sd card :smile:

Edit: Just to be clear, Teletype doesn’t work with USB memory sticks? It has more chances of working with a memory card and a USB adapter?

No, sorry, it should work with any mass storage USB device. I use an SD card reader and the same SD card I use for the aleph.

I’m also having trouble with the USB read/write. I’ve tried three USB sticks, all fairly small in size (<2 GB). I’ve tried formatting to FAT32 on Windows and Mac.

Can we get a semi-monome-endorsed/approved $5-10 stick recommendation?

frustrating that it works fine here as it makes debugging tricky. i’ll get some random other flash drives.

here’s what i’m using:

http://www.newegg.com/Product/Product.aspx?Item=N82E16820139999&nm_mc=KNC-GoogleAdwords-PC&cm_mmc=KNC-GoogleAdwords-PC--pla--Memory+%28USB+Flash+Drive%29-_-N82E16820139999&gclid=CM2Zo8Gp8coCFQKTaQodh80Exw

limit 20 per customer

1 Like

I think the device itself is not the issue. I use exactly the same as tehn and it doesn’ work. If I use an old CF-Card with adapter i have no problem. Very strange

I can confirm. I bought the same USB stick recommended by tehn and it still doesn’t work.

Just to confirm, we stick the USB drive in while the device is powered down, and then simply boot the modular, correct? Should there be any visual cue that presets were saved to the stick? If not, can I make a request for the next firmware to print “Presets successfully saved/loaded” or “Error 42!” to the screen for debugging purposes?