Teletype workflow, basics, and questions



I have a question regarding trigger input behavior.

I’m sending a momentary gate via a footswitch into trigger input 1 of Teletype to reset the first track of Kria. Script 1 has the following code:

KR.POS 1 0 0

The first track of Kria is resetting when I send a gate, but it’re resetting on both the rising and falling edge of the gate. This happens with gates from the footswitch, Just Friends square wave cycles, etc. The hardware reset input on Ansible behaves the same way.

I’d like to be able to reset the Kria track with only the rising edge of a gate, not both the rising and falling edge. Is there some way to specify this behavior? There was a thread where @tehn mentioned this behavior could be altered but I haven’t been able to find how to do so.

Also confused because it seems like riding-edge-only detection should be the default behavior… I’m running Teletype 3.0 and Ansible + polyearthsea.


What are you using as a footswtich and when did you get your Teletype?


I got it from the recent batch of black PCBs, same that need the TR.3 fix (haven’t done that yet).

I’m using an ADDAC Floor Control, albiet inverted through Math’s mixer for appropriate 0-8v response (using a normally closed footswitch when the Floor Control requires normally open). But, using gates / squared CV from Just Friends produces the same result.


Do you have a scope to look at the output of both? Teletype should respond to the rising edge, not double trigger.

I would also double check all your scripts just in case. Have you tried it with other commands or to trigger one of the gate outs on the teletype?


No scope at the moment unfortunately. Does seem like the source of the gate does vary the behavior. Tested a simple TR.P 1 output with the following results: Foot Control (both direct and through a mixer) and Just Friends caused the double trigger; Maths End of rise /cycle, a Teletype trigger output like, and short triggers from Kria/elsewhere don’t seem to cause it. Strange…


I get this behaviour as well if incoming gate/trig is above 5V (e.g. 10V). I if it’s around 5V i only get 1 trigger on rising edge. I’ve used it to great a though.


Amplitude of these trigger sources doesn’t have an effect for me, attenuating any of the sources I’ve tried ends up with the same triggering behavior, so it must be something with the voltage source itself. This is only really an issue for me regarding the footswitch, resetting rhythms manually and such. Will keep playing around with it.


Been searching and cant figure it out - is it possible to reset metasequences with teletype?


Just ran into a possible bug within JF synth mode - I’m not sure if this has ever been addressed or if I’m just overlooking something. Scripts are super simple, just changing the pitches of JF channels and triggering them manually via different scripts. It’s much easier to see in the video below, but basically the problem I’m having is that sometimes certain notes of the chord ring out indefinitely as opposed to being triggered/plucked and then decaying as they should (apologies for video quality!):


I am finding this too. I think I fixed it though. I’ll check tonight, but what I think I found was that I hadn’t specified V for volt before the velocity for one of the command. Eg:
JF.NOTE 6 N 12 8
Instead of
JF.NOTE 6 N 12 V 8
I’m not entirely sure that this was it or it’s fixed though…


Yes I had the same problem too, curious if it’s a bug or my bad code.


I was experiencing the problem even with velocity specified for every note.

I never was able to replicate the problem by doing anything specific, it seemed to happen at totally random times.


I ran into this too.

I believe that I asked about the frozen notes in the Just Type beta thread and @Galapagoose confirmed that it was a bug. Not sure if there are plans for an update. This was right before W/ came out, so I’m guessing most software bug fix focus has been on that.


Ok. I can say that it’s stopped happening now but it was after a number of sessions working on the same patch so I had power cycled a number of times. @Jonny good to know it’s a bug. I don’t need to check every command now!



My teletype is still waiting at Madrid customs office, but it seems that tomorro morning will arrive home. All his new friends here (ER301, Erbe-Verb, Shapeshifter, Nerdseq and Rainmaker, Grid and OP-1, among others …) are waiting for his arrival, so we will have a big party!! :grinning:

In other to spend my time during the waiting time I’ve been reading all the docs I’ve found, and also the Teletype studies. They are so great and are pretty easy to follow. The problem is that I didn’t find any info regarding the “#P” and “#G” pages in TT. I can’t seem to find the logic in them, and no tips on how to use it. From my understanding, the “#P” is the info for the “tracker”, but I don’t know how the numbers are ordered and how they work. The “#G” is even more complex, as in the sprips I’ve found there are 2 different rows of numbers … Are those numbers edditable, or part of Scenes that doesn’t need to be changed?

Sorry if my questions sounds stupid, but could someone throw some light?

Thanks a lot!


#P is a dump of whatever’s in the tracker patterns. This can be handy to have in a scene save, especially if a scene you wish to share depends on some pattern data. So its “page” is just the tracker page.

#G is a dump of the grid state, not often actually useful to include in a saved scene in my experience, but there it is.


saving grid state is very useful for scenes that work as grid based sequences. if it didn’t save the state of grid buttons and faders you would lose your sequences, or you would have to add scripts to copy them to/from pattern data.

if you don’t use grid ops and you create a scene manually in a text editor you can just skip the #G section altogether. teletype code knows how to handle this. (and the opposite of this - you can use a text editor to edit the grid data for your purposes…)


Thank you guys! I think I’ll understand everything better when the TT arrives …


I want to achieve something like this.
Input 1 & input 2, to get OR output in the picture.

So I have

Clock 1 -> Script 1 :
TR.P 1

Clock 2 (/4 speed) -> Script 2

But Pulses will always reset the TR to 0. Is there a way to keep the TR Gate high until Script 2
runs again to TOG the TR back to 0?


It’s late and not at the TT but I think this works:

TR.TOG ? | A B 1 0

Be careful at audio rates as I think there’s a lower limit around 10ms (not 100% on this one).