Teletype workflow, basics, and questions

teletype

#528

Another quick question about JF synth mode - any reason why when I change the note velocity for any given channel to anything other than 0 it would start to trigger at 2x the speed of the incoming trigger?


#529

Are the triggers coming from an external source? I think there was some talk about the Trig ins double firing on rising edge and falling edge.

Further up in this thread: Teletype workflow, basics, and questions


#530

Hmm, so I have just one trigger into channel 6 from Pam’s. If I set each channel’s velocity to 0 it triggers the note according to PNW, but any other V value and it’s twice as fast.

Unrelatedly, if I am taking the mix out, is there a way to turn off a channel entirely? i.e. a three note chord vs a six note chord.


#531

A velocity of 0 means you wouldn’t hear anything, right? Are you saying that it’s triggering based on the light you see? What is the command you’re using in your script?

You would have to allocate the voices specifically with JF.VOX. The x variable would have to be limited to a range of 1-3. You could do this in one script where you increment by 1 and if the number is 3, set back to 1. That’s what comes to mind…I’d have to sit down with my synth to write it out and test it. Let me know if that helps!

JF.VOX x y z

Create a note at the specified channel, of the defined pitch & velocity. All channels can be set simultaneously with a chan value of 0. x= channel, y = pitch relative to C3, z = velocity (like JF.VTR).


#532

I would think so, yeah. So if the first thing I do is enable synth mode and plug a trigger from PNW into input 6, I have each of the six channels being triggered in unison via mix out. If I type in command JF.VOX 1 N 7 V 10, I have channel 1 being triggered at double the speed a fifth up and the rest of the channels the same as before. If I change channel 1 to V 0, the note and volume stay the same but it’s triggered at half the speed as before, the speed according to the trigger in channel 6.

Re: my second question, it also kind of relies on my assumption that V 0 would silence the channel which I am not experiencing. Say I want to take the mix out and only hear channels 1&2, theoretically I could write a script like:

JF.VOX 1 N 7 V 10
JF.VOX 2 N 9 V 10
JF.VOX 3 N 0 V 0
JF.VOX 4 N 0 V 0
JF.VOX 5 N 0 V 0
JF.VOX 6 N 0 V 0

and that should work?


#533

That should work if you’re in transient/sound mode or sustain/sound (the switches on JF). It seems that cycle mode ignores the velocity. How does it react to pressing the F6 key on the keyboard to trigger? Maybe it’s worth sharing what your JF panel settings are too.


#534

Hm yeah, I thought so too. It actually works fine using TT trigger input or F1 to trigger the script. (I’m just realizing now that maybe it wasn’t clear that I was sending the trigger into JF input 6, not TT.)

JF is in transient/sound, all knobs at noon except intone which is fully CCW.


#535

Ok, that makes sense. This behavior seems a little odd and I checked it out on mine. Triggers don’t seem to be respecting the velocity as they cascade from voice 6 to 1. You’re getting a double trigger too which is odd. Might be worth posting about on the Just Type beta thread.

This is what the guide on the whimsical page says:

Physical TRIGGERS on the other hand, will only trigger the envelope, using whatever pitch & velocity are currently set for that voice, encouraging combinations of digital & voltage control.


#536

Not sure if this is the thread to ask this, but anticipating the next batch of arcs to be released soon, is there any plan for developing Teletype and Arc integration? Love seeing the progress of Grid-0ps, but would like to utilize the grid for kria with ansible, It seems more my play style than arc/ansible, But would love to be able to trigger/meta sequence with arc/teletype if possible.


#537

So I’m experiencing what is most likely a problem between the module and my chair. I just connected TT to ES with an I2C connection and updated both modules to the current firmware. However, when I try to execute ES.MODE 1 to clock ES from TT, TT freezes, the metronome stops, and everything becomes unresponsive until a power cycle. I verified that the connections appear to be correct. What am I doing wrong?


#538

This happened to me until I figured out that I had one of my i2c devices hooked up wrong in my chain. Some things would work and then I’d try sending a signal to my ER-301 and the TT would freeze.


#539

Yep. Something is screwy because now none of my TT commands work for any i2c device. I’m using a backpack as well.

EDIT: I now have ES and JF working but for some reason W/ no longer works at all. Doesn’t power up in this case or the case it was previously in. Also, my brand new TXo causes TT to freeze. I haven’t been able to get it to respond to anything even if I use the same cable.


#540

I know this relates to the pattern tracker data but could someone explain how this is meant to be interpreted? I have been comparing it to the pattern numbers that typically follow but haven’t quite been able to understand what they all mean.

#P
0	0	0	0
1	1	1	1
0	0	0	0
63	63	63	63

#541

Sounds really weird.

I’ve noticed that commands that return values to the TT are the most likely to hang first when the i2c bus underpowered (not enough pull-up). That said, I have a crazy setup for testing (8xTXo and 8xTXi) without problems when I used the backpack.

The only way that I can say to debug this is to use the process of elimination - and to make sure that your cabling is as direct as possible. (Don’t use a star topology - daisy-chain your modules.)

Does the TT freeze with just the TXo connected?


#542

resolved in another thread: I2C was plugged in the wrong way round


#543

Still a novice at TT and curious if anyone could help me solve a problem. I’m trying to execute the following to track velocity of Just Type synthesis using a TXi upon each calling of a script:

JF.VOX 1 N P.NEXT TI.IN 1

However, for the velocity to be calculated accurately upon each run of the script, I need a delay. Adding a delay prefix to this code exceeds the line length.

I can use the hardware input to cut down on the character length but I’d like to use the multiple inputs the TXi affords. I can also use a delay in SCRIPT 1 to call this code from SCRIPT 2, but I’d then be using two scripts for a relatively simple action.

Any ideas on how to execute this code with a delay in a single script?


#544

DEL 5: I TI.IN 1
JF.VOX 1 P.NEXT I

does this work?


#545

For some reason I get no response from Just Friends at all using that method. I tried adding a second, longer delay in front of the JF.VOX as well, altered both delay times, still no response.

EDIT: for some reason JF.VOX doesn’t like the I variable, but using that format with two delays does work!

DEL 20: A TI.IN 1
DEL 25: JF.VOX 1 N P.NEXT A

I thought of using a variable previously but didn’t implement the syntax correctly. Still a novice, indeed. Thank you!


#546

Ahhh, yay! I’m glad it works now


#548

Hi guys, I just bought Teletype and I would like to make a two voices allocator like the shifty from Intellijel.

I’m still in the teletype studies, but didn’t find out how to make it work.

Can someone lead me to find a solution ?

Thanks