Teletype workflow, basics, and questions



Just curious - are there any complications to watch out for when updating Teletype’s firmware with a newer USB-C MacBook Pro? I’m gonna have to connect the provided USB A-A cable to a dongle, and, you know…dongles :wink:


Attempting to update the teletype firmware. Downloaded dfu-programmer, but not sure that’s in correctly…Thought it was, since the driver updated, but now I’m not sure. I opened a command prompt. Totally lost as to what to do next…!

I have hardcore avoided firmware updates in the past. How do I “cd to the dfu-programmer folder”? Frustrated/embarrassed. Any help greatly appreciated…windows isnt accepting anything I’m trying to do here. It “cannot find the path specified.”


fwiw I wasn’t able to get Teletype to mount with a usb-c => usb-a cable. (This could totally be user error; I haven’t attempted to update the firmware in the past.)

I have an a-a on order now. I will update once it arrives and I try via the dongle.


Unfortunately I am rather clueless outside Linux/OSX. Did you happen to see the info here?


@quixot cd is the command for “change directory”, here’s some basic info of how the command works for navigating on windows.


Hey thank you!! It now reads:
Teletype: 8CBC031-DIRTY

Does that mean it worked…?


Nice! That means the latest commit you have has the hash 8CBC031 so… looking at

it’s the commit where PR141 has been pulled into devel.

The DIRTY is because you’ve built from something not tagged as a release (I think?). Where’d you get the zip file you built from?

EDIT: ah, looks like you most likely built from 2.2.0. Latest commit on that release is 8CBC031

EDIT 2: So I forgot about which I opened, whoops! Let me see if I can figure out if anything needs to be changed there. The prompt should read the version in addition to the hash of the commit (so you don’t have to ask the question, “did this work right?”)


Sorry, got pulled onto a work call :expressionless: Yeah, i used the one that you had above. The one that is supposed to work with W/.

Edit: seriously, thanks again. The stressful part of that was so short with the help here. And now the EVERY and turtle commands work. Hurray!


Worked fine for me. 20 20 20.


Dumb question that might have been answered elsewhere: can teletype generate LFOs?


Answer is yes! Much easier if you have the TxO expander, but it still can be done. Just change the CV output voltage periodically bewteen two values with with slew on and you get a basic triangle LFO. I don’t think you can generate any other waveform without TxO.
EDIT: or maybe you can change CV.SLEW between the rise and the fall and generate a sawtooth


TT is excellent for random LFO type stuff. Just set the CV output to a random voltage every so often for a stepped random, and add some slew for a smoother wave.

The newest TXo firmware has many more wave forms, and proper LFO ops.


@Justmat @beforeitwascool

thanks! been playing around with my setup for a while now and thinking that I can ditch some of the modules in there (Batumi, maybe Wogglebug and Disting) for what I need. I have a Bastl CV Trinity so wondering how Teletype could possibly enhance/augment/add to what that module does.


One of the first things I did with TT was make a tempo-synced sawtooth.

CV.SET 1 V 5
CV 1 0

I guess you could approximate curves by updating the target CV value and/or slew rate more frequently than the LFO rate; use Excel or something to work out “wavetable” values to store in a pattern.


What is the line length limit? I can’t find it in the manual and I’d like to do some coding away from home today.


6 lines per script.

20 characters per post :laughing:


The line length limit is 30 characters if I remember correctly.


30 Confirmed. I was surprised - thought it was closer to 20.


should be 31 char max length


I filled a line, counted it twice. Tried to add another char and confirmed I had the max line length. Counted again: 30.

That said, I did get out of bed specifically to boot the TT and my dozy brain may have miscounted three(!) times.

Is it definitely 31?