Telex: Teletype expanders


#1180

Ah, I managed to miss the manual, wrapped up with the invoice in the outer box! Thanks.


#1181

don’t own a Rosie- but are the A and B inputs actually stereo, or are they summed to mono, and just the FX return is actually stereo?


#1182

Don’t have one either, but according to the Make Noise page, Rosie features:

Two Mono Inputs (Channel A and B) w/ LED indication of signal strength

Looks like you might be able to pass through some stereo signal using the Aux returns as additional inputs:

http://www.makenoisemusic.com/modules/rosie

Good luck! :slight_smile:


#1183

I set up an LFO on my TXo’s 4th output that oscillated between 0V and 10V like this:

TO.CV 4 V 5
TO.OSC.LFO 4 50
TO.OSC.CTR 4 V 5

This causes an LFO with a 5V +/- swing to center around 5V. It was patched to the first input of my TXi. For TXo output 1, I wanted to just deliver the quantized CV value on each metronome pulse. For TXo output 2, I set it to 6V on the init script (TO.CV 2 V 6) and then set it to oscillate at the given pitch on each metronome pulse as well. Here is that metronome script:

TO.CV 1 TI.IN.QT 1
TO.OSC.SET 2 TI.IN.QT 1

That’s it. I patched the first TXo output into the 1V/oct input on my O-Coast. I mixed the square wave output of this in with the TXo output 2 (which is oscillating). With the tuning dial on the O-Coast, I was able to offset the two oscillators (which is why their chromatic sweeps happen at different times).

Hope this helps.


A bit more on Quantization on the TXi

TI.IN.QT x returns the voltage as a number (-16384 to 16383). The input voltage is quantized to the nearest note value in your selected scale (TI.IN.SCALE x - defaults to Equal Temperment). TI.IN x will show you the voltage that is read at the input. These two will differ unless the input value is exactly the same voltage as a particular note.

TI.IN.N x returns the quantized note number for the particular voltage that is read on the input (again, based on that input’s scale). This number is not a voltage - it is a note number. You can convert it to a voltage by either a) using the Teletype’s N operator (e.g. CV 1 N TI.IN.N 1 - where the scale automatically becomes ET) or by passing it to the TXo’s N operators (e.g. TO.CV.N 1 TI.IN.N 1 in whatever scale you have set on the TXo).

What is tripping you up, I think, is your MAP command. You are mapping all voltages to the range 0-23 - out of the full potential range of -16384 to 16383. I’m assuming all of those voltages are quantizing to zero. Depending on your input, you would want to map its voltage ranges appropriately. Remember, map is bipolar (as the inputs are -16384 to +16383). For example, TI.IN.MAP 0 16383 will take a bipolar +/-10V and map it to 0V-10V, centered around 5V.


#1184

Forgive my ignorance, but are there any more plans for busboards/backpacks anywhere, or does anyone have any partially built? I’m fine with some assembly, but I can’t do SMD soldering.


#1185

I’m currently doing another run of the TXb. Should be done in a month or two. Just waiting on the panels. If you are antsy and want to make one yourself, it is open source and available up on my GitHub page for the TXb.

You can also grab/make a lovely TT-Busboard-Jr. Don’t be put off by the number of pins - i2c can be daisy-chaned. They are functionally identical from a “pull-up” perspective. :slight_smile:

Finally, you can make one of the original busboards that mount on the Teletype:

There are only 3 SMD parts. If you are comfortable with through-hole soldering, this would be only a small step-up in skill. Watch this video for 40 seconds and you will learn everything you need to know:


#1186

Thank you, fantastic writeup <3 Will have to dig in and see what I can learn. Much appreciated.


#1187

I just got my ER-301 today, and started my first foray into i2c with Teletype / TXb / ER-301.

If I connect Teletype directly to the ER-301, SC ops work fine.

If I also connect Teletype to the TXb, SC commands cause Teletype to freeze. I don’t have power connected to the TXb, nor anything else (my intent is to use it for the 16n Faderbank).

I assumed the silver stripe on the TXb indicates the row of ground pins (making the middle SCL and the opposite side SDA). Is that incorrect? It’s not in the info that shipped with the module.

I also assumed I didn’t need to connect power to the TXb since my Teletype is recent-ish…


#1188

To me, this sounds like you have plugged in I2C wrong, that’s exactly what happened to me when I had.


#1189

OK, more testing now that I have a continuity checker:

  • I can’t detect any shorts or anything on the TXb.

  • on the TXb, ground is the row of pins marked on the PCB with a stripe.

  • I was definitely connecting Teletype to ER-301 correctly.

  • If I connect Teletype only to TXb, or to both TXb and ER-301, it still freezes when I issue an SC.CV op.

  • It freezes whether I connect the pins in the same order (GND, SCL, SDA) as I had been doing, or if I reverse SDA and SCL.

  • It does not freeze if not connected to anything, or if I connect only the GND pin. It does freeze if I connect GND and SCL or GND and SDA.

  • I tried another set of 3 jumpers, same result.


#1190

Very weird. (Yes - the silver stripe is ground. Don’t know how I missed that in the documentation. Seems important. Sigh.)

How long are the cables you are using to connect between the devices? Do all of your cables check-out continuity wise?


#1191

They’re 20cm, and yeah, the continuity checks out.


#1192

Problem solved – I have an older Teletype without the pullup resistors, so powering TXb fixes it :+1:

For some reason I had been assuming it was one of the new ones, but then I found the thread where it’s mentioned the new ones have black PCBs, not green. :blush:


#1193

Whew!! Took troubleshooting to
PM and I was getting more and more perplexed as nothing was seeming off in the details.

Glad you are up and running. Enjoy!!!


#1194

I’m having a lot of trouble with my Teletype locking up and I think it might be the TXi? (sorry if this post belongs somewhere else and also its length.)

I’m using an at least third-hand greenback TT with a purple backpack (not sure who made it) with the following connected for now: Ansible, Just Friends, TXo+, TXi. Unfortunately, the i2c jack on the TT looks like it was soldered in crookedly, but the previous owner suggested it wasn’t a problem for him and it generally seems to be ok.

I spent a couple hours yesterday redoing all of the i2c connections, attempting different combinations of chaining them together, etc. I’m currently on the latest RC version, but did try downgrading to the official 3.0 to no avail. I was using the following scripts just to put everything in the mix with triggers from Ansible Meadowphysics:

I
TO.CV.SET 1 8 V
TO.ENV.ACT 1 1
TO.CV.SET 2 8 V
TO.ENV.ACT 2 1
JF.MODE 1

TO.ENV.ATT TI.PARAM 1
TO.ENV.DEC TI.PARAM 2
TO.ENV.TRIG 1

JF.VOX 1 N 1 V 5, (ETC FOR THREE NOTES)

TO.ENV.ATT 2 3
TO.ENV.DEC 2 3
TO.ENV.TRIG 2

ME.RES 0

After messing around with the wires for a while (I don’t think it was problem, but wanted to start there), I was able to get the non-TI.Param’d TXo envelope and JF chord to keep going with an occasional manual F4 Meadowphysics reset for about a half hour. When I reintroduced the TXi’d envelope, it locked up after a couple repeats. I did notice that my TXi comes apart super easily and I tried tying the boards together with fishing line, but that didn’t seem to improve the situation. I had to stop there to deal with some life issues, but I’m not sure what to try next.


#1195

Seems like there are too many variables in the setup to easily diagnose it. I would try removing the other modules from i2c and test just the Txi, Txo, and backpack.

If that fails, test just Txi and Txo separately with backpack.

Then if still failing, test the 2 separately without the backpack. You should be able to isolate the issue this way if it’s a problem with those components.


#1196

Thanks, @Jonny. Agreed, it’s super convoluted.

When I was rewiring the i2c, I did test everything in combinations and gradually adding modules, but I was getting a little frustrated by that point. I’m not sure if TXo and TXi was one of the combinations, but I’ll try that and keeping a log later today.


#1197

Huh, I did get a couple of TT lock-ups as well this weekend, but I can’t remember if I was heavily taxing the TXo or the TXi. If I have time this week, I’ll run a couple of tests as well…


#1198

Arg. Sorry you are having problems.

This is usually a symptom of having a bus that is unstable. Reads are the first to go in my experience. This happens while the Teletype is waiting for a response on the bus. (If the bus hangs immediately regardless the command, you are having another problem altogether.)

How many devices are connected to your Teletype? Is you bus board powered? Are your cable runs as short as possible?

I concur with the advice from @jonny - try the process of elimination to see when your bus becomes unstable.


#1199

Hi @bpcmusic,

-I’m pretty sure the bus is powered. I think it’s this one that used to be in your store:

https://cdn.shopify.com/s/files/1/1856/2693/products/backpack_installed_1024x1024.jpg?v=1497805600

-I have four modules connected: Ansible, Just Friends, TXo+, and TXi.

-I’ve tried a couple different lengths. I have the ones that came with the TX’s, ~4” and ~8” generic jumpers, and a couple longer more professional looking ones. I also tried piggy backing everything and sending everything straight to the bus. Everything is in a 4U Intelli case with not too much else and grouped right next to each other.

-I’ll definitely try testing more methodically today or tomorrow. Already got a spreadsheet going.

Thanks!