Telex: Teletype expanders

As you mention the TXff prelude - feels like a good point for transitioning into recapitulation and coda…

:grinning:

1 Like

Considering doing a couple TXi’s the DIY route. I know I can get panels from OSHPark, but I’ve never had a panel made. Can anyone point me in the right direction?

Front Panel Express is pretty easy. Though I know @MichiganSynthWorks had some bad experiences with them. My 1u TXi FPE design is attached earlier in this thread and it would be very easy to adjust it back to 3u in their software.

1 Like

Thanks to @bpcmusic for helping me dying this setup!

Much appreciated!

Now got to learn how to program the txo -txi!

3 Likes

I’ve scored panels and PCBs for TXi and TXo from another lines user and am excited to get into the whole world of expanded teletype. I’ve done some through hole soldering and am wondering if it’s crazy to treat these as a home build project for an SMD beginner? Any advice? Was thinking of going down the hot air route but wasn’t sure if I’d regret biting off more than I can chew!

Can’t say if their beginner friendly, as I haven’t seen the boards.

There’s a great thread with lots of info here:

However, I would get hold of a few passive components and do a little test run with some strip board.

Happy soldering and good luck!

1 Like

The parts are pretty small to solder but it was in fact my first SMD project after a lot of through hole and while it needed some trouble shooting it worked and I was pretty proud when I finished it.

If you are hesitant I think Music Thing’s SimpleEQ is considered as a great first SMD project (and it is useful too in delay feedback line for example). Also I find the NLC projects nice to work on - more but bigger parts compared to the TX.

I would have never expected this to happen, but only a few projects later I am now at a point that I prefer SMD over through hole for convenience…

2 Likes

hi, i’m about to build my TXi and TXo. just got a pcb+panel from this forum.
want to ask does anybody has done the TXo+ upgrade? how difficult is the upgrade? does it stable? does the improvement feature worth the upgrade, or most of you doing fine without the upgrade?
i’m still considering if i should do the upgrade or not…
any opinions/comments are welcome.
thanks in advance :pray:t4:

Where do people get panels and pcb’s from? Is it just a matter of lucking out with the trade ads?

upgrade is by no means mandatory. if you use the txo as an oscillator frequently, the upgrade gets you more waveforms, a higher sampling rate, and less aliasing. it is pretty easy to put together and a pop in replacement for the old teensy. you really don’t need to change the few parts on the tx that i started doing differently - the have only a slight effect bringing in a teensy teensy more high end.

3 Likes

thanks for the clarification Brendon! :pray:t4:

1 Like

Seem to have gotten my TXo (bought from @bpcmusic in the last batch in Jan 2019) into a bit of an odd state, where using envelope gate ops (TO.ENV ch gate) causes an envelope only after releasing the gate. That is, I have only TT and TXo connected via I2C, and immediately after power-on I can run the following, either with or without doing TO.CV.INIT 1 first.

TO.CV 1 V 5
TO.ENV.ACT 1 1

In live mode I then run TO.ENV 1 1 and the envelope does not open, but after I run TO.ENV 1 0 it pulses, as if I had run TO.ENV.TRIG 1 (which still behaves normally). This was working as expected a few days ago, with TO.ENV 1 1 opening the envelope and TO.ENV 1 0 closing it.

Teletype is on the 3.1.0 release firmware. I have possibly been sending TXo a bunch of weird I2C messages during development of I2C leader mode for Ansible. Reckon I’ll attempt to reflash the TXo firmware next, but found it very curious that I could get behavior like this that is now persisting across power cycles.

This is just a heads up on a weird problem that I found with a home built TXi (actually built by Rob Spencer’s Southside Synthesiser Repair in Glasgow). With no jumpers connected the module seemed to be reading the jumpers as if they were all set to 1 (we discovered this by using the debug mode with the teensy plugged into USB). This meant that the module wasn’t responding to anything from the TT over the I2c bus using the usual 1-4 numbering. Looking at the schematic it looks like the input pins for the jumpers are floating so I wonder if that’s the problem? Could this be something to do with the particular components that we bought?

In any case we solved the problem by hard coding the cfg variable to be zero in the code in the setup function.

Hope this might be useful if anyone else is having a similar problem. Although I would also be interested to know why this issue occurred for us but doesn’t seem to have been reported elsewhere.

1 Like

Hey @SimonKirby, it’s me Rob. Decided on @GoatFarmer :slight_smile:

I think you’ve persuaded me to enter the world of Teletype :slight_smile:

I do have a question to the forum… What’s the accepted norm for building these? I’m happy to do a very limited run, but don’t want to go against the grain :slight_smile:

4 Likes

You’ll want to ping @bpcmusic but his licenses do allow commercial use. Cc-by-sa 4.0 on the hardware.

1 Like

Doesn’t look like a can message @bpcmusic directly at the moment being such a noob :slight_smile: Maybe he’ll reply here?

1 Like

staff notice/reminder: forum rules prohibit attempting to buy, sell, solicit buying/services/etc outside of the Trade category. please keep this thread clean; limit any buying/selling to Trade or PMs.

  • don’t attempt to buy, sell, trade, offer or solicit paid jobs & services, etc in other categories outside of Trade.

No worries at all. I used to run a thing called GMSN! which I closed down for exactly the same reason :slight_smile:

Thought I would check what the rules were first :slight_smile:

Behavior is still the same after this, TO.ENV.TRIG 1 works but TO.ENV 1 1 doesn’t open the envelope. I also tried a TO.CV.RESET 1 in case maybe the software was confused about the current CV value when calculating the envelope samples or something? No effect. I’m left wondering if this is possibly a hardware issue or something, though all the CV outputs seem to work fine otherwise, and measure fine on a multimeter, very odd. Has anyone encountered something like this? This is actually a TXo+ so it’s using a Teensy 3.6.

@csboling - weird. should work. i’m on the road this week; i’ll post a full example script when i get back to LA. doubt it is hardware…

1 Like