Telex: Teletype expanders


#562

Sounds like your i2c cables may not be oriented properly. Ensure that your ground wire is accurate. Here is an excerpt from the quick start guide (pages 3-4):

  • On the Teletype and Trilogy Modules, the II pins are oriented top to bottom (ground on the top).

  • On the TELEX modules and Ansible, these pins are oriented bottom to top (ground on the bottom).

  • On the TELEX modules, two vertical columns of II pins are present and slightly separated (2x3 connectors won’t cover both columns – they are designed for jumpers).

Ensure that you are appropriately orienting your ground wire when connecting the devices together. The rule is “Twist to the Teletype or Trilogy” - if you need a mnemonic.

Let us know if that solves your problem. :slight_smile:


#563

Smacks head yup that was exactly it, the cable connecting the TXi was reversed. I was surprised this effected Ansible as well! Glad that didn’t damage anything… all seems to be working now. Haven’t noticed ay vortexes yet, but I’ll keep an eye on the sky :wink:


#564

Are pictures of correct hook up posted somewhere? It might be helpful to have this properly presented (AND the trilogy modules as well)…


#565

This is tied to your configuration - there is no single correct hook up. Your setup varies based on the modules that you have on the bus, how they are arranged in your case and what bus board you are using (if any).

An important factor is that your cables are oriented properly. The various modules in the ecosystem are inconsistent in their placement of the ground wire as it relates to the vertical orientation of the module. If you flip the connection somewhere, commands to external modules will hang the Teletype. Look on the PCBs for the ground annotations and check that your cable is oriented properly.

Equally important is the number of devices on your bus. If you have (approximately) four or more devices, you will need a powered bus extender (the iiBusboard or the iiBackpack). (The original bus expander that simply supplied a few additional pins is not adequate in this case as it does not supply the additional voltage that is needed to strengthen the bus.) Without this, you will find that remote commands will frequently hang your Teletype due to the insufficiently powered bus.


#566

at the risk of sounding annoying: any info on current consumption yet?

sorry for bugging, I just have them around the corner (excitement!) and need to be careful with my skiff.


#567

Also reversed one of the cables at first. Now everything is running perfectly. I’ve been months dreaming of things to do with four more inputs, and it will be years of discovery now! Opens things up exponentially for my particular approach.


#568

Maybe I missed it somewhere, but is there any info regarding the TO.ENV shape? Is there a way to set log/lin/exp envelopes?

Really loving the TXo so far! So much so that i’ve barely touched the TXi. More fun ahead :smiley:


#569

Received mine today, and works as expected (and passed through custom without any problem…) :slight_smile: Thanks again for the hard work Bendon.


#570

@jnoble - have you taken a peek at power consumption? I haven’t had a chance as I’ve been traveling and shipping. :wink:

Horray!!![quote=“courdek, post:568, topic:1379”]
Is there a way to set log/lin/exp envelopes?
[/quote]

Envelopes are currently linear. I’ll start maintaining a feature request list somewhere and put this on the list. As I think about it, the computation might be a bit of a resource trick (especially while running oscillators).

Fantastic! Let us know how you use them!!


If you filled out the shipping form, just a reminder: I’m boxing, calculating and sending emails over the weekend. Shipment #2 will go out on Monday.


#571

Are these all sold out?


#573

Last night, I set up TXo/TXi/Just Friends with Teletype firmware 1.4.1 (the hex included above in this thread) on one of the ii backpacks without a hitch!


#574

Telex current consumption:

TXi: 46mA +12V / 5mA -12V
TXo: 51mA +12V / 7 mA -12V

Measured with a fairly reliable Fluke 87; TXo had all its LEDs on full brightness.


#575

Nice! Not terribly thirsty at all.


#576

Yes - but we might have a few extras available due to cancellations. I’ll know early next month after the final shipment date (June 5th). No lists are being kept yet.

YES!!! Glad it went well. Would love to hear about your experience and how you are using them!

You are awesome!! Thanks so much for helping out here! Sincerely appreciated.


#577

Late at the party as usual. Well, if there’s cancellations, please keep me posted as well!


#578

The 2.0 firmware will soon have some handy new ops and aliases for TELEX users. Just submitted a pull request to the repo.

I’ll be able to optimize the init commands in the future. Right now they reset state via multiple commands from the Teletype. When I next update the TELEX firmware with a substantive change, I’ll coalesce all of those commands into a single function the Teletype can call. It won’t be noticeable, but will be good hygiene. :slight_smile:


#579

I started messing around with TO enveloppes, waited for a long time something like that for my TT, so i started asking myself if enveloppes curves are part of the plan for the future ? ( yeah people always want more :innocent: )


#580

This isn’t the first request for this feature (right, @courdek) . :slight_smile:

It is certainly on the list. The challenge is that we are a bit maxed out when in full oscillator + envelope mode on four channels. Adding in some more math to calculate the spot on exponential or logarithmic curves will add an extra demand on the processor - even if we use lookup tables. I’ve been meaning to come up with some sort of resourcing metric so that the TXo knows its current workload and can make smart decisions about these things.


#581

TELEX Shipping Update

Getting ready to finalize Monday’s shipment. To date:

  • Everyone who has filled out the Google form has had their shipment boxed, weighed and been given final pricing.

  • Everyone who has sent a PayPal Payment has had their tracking number generated and shipping label affixed to their box. The handful from this weekend are sitting, ready to go to the post.

Monday will be the last shipment that I do before June 5th. I will not be processing any shipments until the weekend before that date as I will be out of the country (again).

Any orders not shipped by that date will be put back on the market for others to purchase. It is my sincere goal to have all of the units I produced in the wild by mid-June. It will be first come, first serve on the cancellations after the 5th. I’m not taking pre-orders for them, but I’m certain that there will be a few units available.


We have a handful of folks who have been priced and have had their boxes prepared, but haven’t sent the corresponding payment. We also have a few that have been contacted via the forms and haven’t filled out the Google address form. Bummer - I want you guys to get your TELEX!!

I’ll be sending out reminders over the coming weeks, but if you are reading this wondering what is happening with your shipment, you most likely fall into one of those categories. I’d hate to have your waiting for your unit due to my schedule - or to miss out on your reservation. In other words, get a move on it! :wink: :wink: :wink:


#582

chiming in to mention my interest in case of extras as well :relaxed:

really kicking myself for not jumping on this earlier!