Telex: Teletype expanders


#1188

To me, this sounds like you have plugged in I2C wrong, that’s exactly what happened to me when I had.


#1189

OK, more testing now that I have a continuity checker:

  • I can’t detect any shorts or anything on the TXb.

  • on the TXb, ground is the row of pins marked on the PCB with a stripe.

  • I was definitely connecting Teletype to ER-301 correctly.

  • If I connect Teletype only to TXb, or to both TXb and ER-301, it still freezes when I issue an SC.CV op.

  • It freezes whether I connect the pins in the same order (GND, SCL, SDA) as I had been doing, or if I reverse SDA and SCL.

  • It does not freeze if not connected to anything, or if I connect only the GND pin. It does freeze if I connect GND and SCL or GND and SDA.

  • I tried another set of 3 jumpers, same result.


#1190

Very weird. (Yes - the silver stripe is ground. Don’t know how I missed that in the documentation. Seems important. Sigh.)

How long are the cables you are using to connect between the devices? Do all of your cables check-out continuity wise?


#1191

They’re 20cm, and yeah, the continuity checks out.


#1192

Problem solved – I have an older Teletype without the pullup resistors, so powering TXb fixes it :+1:

For some reason I had been assuming it was one of the new ones, but then I found the thread where it’s mentioned the new ones have black PCBs, not green. :blush:


#1193

Whew!! Took troubleshooting to
PM and I was getting more and more perplexed as nothing was seeming off in the details.

Glad you are up and running. Enjoy!!!


#1194

I’m having a lot of trouble with my Teletype locking up and I think it might be the TXi? (sorry if this post belongs somewhere else and also its length.)

I’m using an at least third-hand greenback TT with a purple backpack (not sure who made it) with the following connected for now: Ansible, Just Friends, TXo+, TXi. Unfortunately, the i2c jack on the TT looks like it was soldered in crookedly, but the previous owner suggested it wasn’t a problem for him and it generally seems to be ok.

I spent a couple hours yesterday redoing all of the i2c connections, attempting different combinations of chaining them together, etc. I’m currently on the latest RC version, but did try downgrading to the official 3.0 to no avail. I was using the following scripts just to put everything in the mix with triggers from Ansible Meadowphysics:

I
TO.CV.SET 1 8 V
TO.ENV.ACT 1 1
TO.CV.SET 2 8 V
TO.ENV.ACT 2 1
JF.MODE 1

TO.ENV.ATT TI.PARAM 1
TO.ENV.DEC TI.PARAM 2
TO.ENV.TRIG 1

JF.VOX 1 N 1 V 5, (ETC FOR THREE NOTES)

TO.ENV.ATT 2 3
TO.ENV.DEC 2 3
TO.ENV.TRIG 2

ME.RES 0

After messing around with the wires for a while (I don’t think it was problem, but wanted to start there), I was able to get the non-TI.Param’d TXo envelope and JF chord to keep going with an occasional manual F4 Meadowphysics reset for about a half hour. When I reintroduced the TXi’d envelope, it locked up after a couple repeats. I did notice that my TXi comes apart super easily and I tried tying the boards together with fishing line, but that didn’t seem to improve the situation. I had to stop there to deal with some life issues, but I’m not sure what to try next.


#1195

Seems like there are too many variables in the setup to easily diagnose it. I would try removing the other modules from i2c and test just the Txi, Txo, and backpack.

If that fails, test just Txi and Txo separately with backpack.

Then if still failing, test the 2 separately without the backpack. You should be able to isolate the issue this way if it’s a problem with those components.


#1196

Thanks, @Jonny. Agreed, it’s super convoluted.

When I was rewiring the i2c, I did test everything in combinations and gradually adding modules, but I was getting a little frustrated by that point. I’m not sure if TXo and TXi was one of the combinations, but I’ll try that and keeping a log later today.


#1197

Huh, I did get a couple of TT lock-ups as well this weekend, but I can’t remember if I was heavily taxing the TXo or the TXi. If I have time this week, I’ll run a couple of tests as well…


#1198

Arg. Sorry you are having problems.

This is usually a symptom of having a bus that is unstable. Reads are the first to go in my experience. This happens while the Teletype is waiting for a response on the bus. (If the bus hangs immediately regardless the command, you are having another problem altogether.)

How many devices are connected to your Teletype? Is you bus board powered? Are your cable runs as short as possible?

I concur with the advice from @jonny - try the process of elimination to see when your bus becomes unstable.


#1199

Hi @bpcmusic,

-I’m pretty sure the bus is powered. I think it’s this one that used to be in your store:

https://cdn.shopify.com/s/files/1/1856/2693/products/backpack_installed_1024x1024.jpg?v=1497805600

-I have four modules connected: Ansible, Just Friends, TXo+, and TXi.

-I’ve tried a couple different lengths. I have the ones that came with the TX’s, ~4” and ~8” generic jumpers, and a couple longer more professional looking ones. I also tried piggy backing everything and sending everything straight to the bus. Everything is in a 4U Intelli case with not too much else and grouped right next to each other.

-I’ll definitely try testing more methodically today or tomorrow. Already got a spreadsheet going.

Thanks!


#1200

Yep - that’s the powered bus board that brian designed and open-sourced. It should provide you good pull-up with short cable runs. You should be fine with just four modules on it. I’ve had over sixteen at one time - but I’m nuts.

I’d start with the TXo and do a burn-in read test with only it connected. Make sure it is flashed with the latest firmware and go to town with something like this in your metronome script:

L 1 4: P I TI.PRM I
L 1 4: P + I 4 TI.IN I

See if it runs for a while and is remains responsive. The pattern screen will show updating values. You also can try faster metronomes to put some stress on the thing.

You should also try reads from the Ansible. Theoretically, the Teletype should suffer from the same bus issues for reads with it as the TXi.

We’ll get this figured out!!

BTW: It doesn’t look like I built that one (or the TXo and TXi on either side). The purple PCBs to the sides are a giveaway - I only used OSH Park for prototypes of the Telex (unless you have one of the beta units I let out of the lab). I did use OSH Park for the backpacks when I made them - but would have put an orange dot in the blank space underneath the power connecter to show that it went through QA testing. Kinda cool to see ones built by others in the wild. :slight_smile: :slight_smile: :slight_smile:


#1201

(Personal paranoia: if you (or anyone) find the trouble is with the board and it’s one that I built, please reach out and I’ll make it right as quickly as possible.

Might not be mine! But I was never able to replicate lockup to begin with, so I wasn’t able to test that my boards helped with the issue.

Paging also @Olivier, though looking back I don’t think you bought a TT board directly from me. If you got it second-hand and can share privately where it came from, I’d appreciate it. Thanks!)


#1202

Confirming that I did not purchase a TT board from you – bought it direct from @bpcmusic last spring when I first got my TT.

It’s been working like a champ for a year, and I only experienced lock-ups in the last week after installing TXi. I am using rather lengthy cables for a couple of connections, and everything is going straight to the board. Perhaps I’ll try daisy-chaining a few things instead next weekend.


#1203

@xenus_dad & @OliverMiller - Hope you took my aside above as intended - excitement to see modules in the wild that other people built! It is an awesome feeling to see them having a life of their own. (It also gives me some relief that folks will still be able to get them as I’m not planning to do any more bulk builds of the Telex.) :slight_smile: :slight_smile: :slight_smile:

More thoughts - If it works at all, I am more suspicious of your cabling than the TXi. And maybe that busboard. If you have a voltmeter, try connecting just the busboard to power (disconnected from the Teletype and your modules) and check to see if you get 3.3V on the SDA and SCL lines. That would rule out if there is a problem with the regulator on the busboard.


#1204

It is exciting! I wasn’t reacting at all to your comment so much as the idea that I might have put something out into the world that is not working correctly, which gives me the personal heebie jeebies.

I’m excited to both have BPC-built TelexX modules, and to be able to build my own at some point.

Everything all good: just, as it turns out @merlatte’s backpack was indeed one of mine, I want to either help eliminate the board as the source of the problem or else fix the board as quickly as possible.


#1205

It might also be instructive to get a picture of the other side of the busboard - to confirm pull up resistor values?


#1206

Just to be clear, the picture of the board I had posted was just a Google image for identification purposes. My TX’s were both from the recent BPC batch. This is both sides of my actual board. Can get closer/better pics if need be:

@bpcmusic Unfortunately, no voltmeter. There’s a slight chance that I can borrow one from work tomorrow, though. I’ll try to double check my cabling later tonight. Usually, it was just a couple repeats before locking up when I had the TXi in play.


#1207

that SDA resistor looks a touch dodgy to me, but hard to tell without a closeup