Torii

sending from a NAVA 9 drum machine into a iConnect box.

yes…start and stop messages.

thanks for the help!!!

1 Like

Thanks, that did it fine!

Updated to v0.4.0

  • reworked to implement global clock
  • requires norns version 200424
  • submitted to community script repo
7 Likes

question re:global clock and crow integration. I’ve updated to the latest version of Torii, and i’m trying to clock it externally via crow. I can select crow as a clock input from the global clock settings, and it appears to be picking up the correct bpm. but, in the Torii params, the choices are only clock internally or externally. theres no specific setting for crow. and when I select external, it doesn’t seem to be picking up the global clock.

i know you’re hauling ass on the mi engines (which will be epic), so no rush on this, but when you get a chance, would be greatful if you could take a look see

huh… I can’t remember what I did there. Will need to take a look.

There might be a left-over param thing I didn’t fix for global clock. I’d think the CLOCK params would override. (like ignore the params int/ext thing?)

Since I don’t have crow its hard to test that use-case.

@gnome666 Something sounds wrong about this. In the current script there are no other params for clock internal/external. Only global clock in the CLOCK section.

Are you seeing v0.4.0 at the top of the script?

hey ya!

been delving into Torii as of late.
:stuck_out_tongue:
would it be possible to add clock dividing to Torii so the user could run the sequence at different speeds?

also…
when i activate a step i can’t turn it back off or remove it.
the light will turn off on the bottom Grid row but the audio will still pass through.

it also has a longer envelope time when i activate a step instead of the short envelope that it seems to default to at startup.

to get around that i have to hit random(K2) so it will “reset” any steps that i may have activated.

Hey Spike! thanks for the report.

I’ll have to take a look at these things. I probably don’t have the steps checking env params when they get added.

How are you activating the step and then removing it? From the encoders or grid?

Clock dividing seems doable tho.

1 Like

i’m activating steps from a Grid.

update v0.5.1

  • added clock divider (see params)
  • fixed grid keys activation for steps
  • row 7 will clear the env amount if hit while selected

Todo:

  • look at env changes getting properly updated

Questions:
From the grid - Currently a step needs to be activated (row 8) and have an envelope amount (rows 7-1) for it to play. I don’t have a way to zero the env from the grid tho. Is that needed?

1 Like

If you have an example of this I’d be curious to see. Currently the envelopes are not done per step, but rather whatever is in the params for Filter Env ADSR and Envelope ADSR (which should be Amp ADSR i think) should be the same for all steps.

1 Like

i just updated…and…well pretty much all the problems are gone!
THANK YOU SO VERY MUCH!
:stuck_out_tongue:

the clock divider is awesome!
thank you for displaying on the front screen as well!

ran into an issue on the GRID…
the play head only goes up to step 17 and 18 then disappears.
however it does display on the norns screen correctly.

step one won’t turn off completely.
it stays on in a dim state.

question…is there a way to add a MIDI start/stop…as in it will reset and start from step one when i hit play?

it was a primary noiz manipulator for tonight’s broadcast:

1 Like

Yeah that’s an easy add.

The other playhead stuff I’ve already got on my list to look at :grin:

2 Likes

Updated again for MIDI Start/Stop/Continue. (see Github)

Also added a LP Ladder filter with an LFO mapped to it. That happens pre-gates. Not sure how useful this really is just yet. Gonna see about syncing LFO to clock.

Also just fixed playhead/cursor grid led weirdness

3 Likes

Just a question
Even putting the script on bypass, the output levels appear to be lower than the input levels
see video:


The sequencer levels all seem to have the same volume even when setting patterns at different heights. This is expected? It reminds me very much of the functionality of MIDI Murf, but it would be great if each line of the sequencer matched the velocity and therefore the amplitude of the VCA.

Thanks.

I’ve been playing with the filters, so maybe that’s involved with the levels. I’ll check more tomorrow.

Note the level for each step is filter env amount not amp env amount.

1 Like

Yes i can try I tried to close the filter and increase the filter’s envelope:) really cool

@okyeron
hey ya!

i just updated to the latest norns OS (200604)and was doing some house cleaning.

i ran an update on all the scripts and i am running into an issue.

one out of three norns is giving me: error: load fail
(the other two are running fine)

  • removed the script and reinstalled
  • fresh restart
  • error: load fail
  • used Cyberduck to delete the folder and ;restart from maiden
  • got error: load fail

this is what maiden says:

Summary

script load: /home/we/dust/code/torii/torii.lua

cleanup

script clear

SCRIPT ERROR: load fail

/home/we/dust/code/torii/torii.lua:41: module ‘r/lib/r’ not found:

no field package.preload[‘r/lib/r’]

no file ‘/home/we/norns/lua/r/lib/r.lua’

no file ‘/home/we/norns/lua/core/r/lib/r.lua’

no file ‘/home/we/norns/lua/core/params/r/lib/r.lua’

no file ‘/home/we/norns/lua/lib/r/lib/r.lua’

no file ‘/home/we/norns/lua/softcut/r/lib/r.lua’

no file ‘/home/we/dust/code/r/lib/r.lua’

no file ‘/usr/local/share/lua/5.3/r/lib/r.lua’

no file ‘/usr/local/share/lua/5.3/r/lib/r/init.lua’

no file ‘/usr/local/lib/lua/5.3/r/lib/r.lua’

no file ‘/usr/local/lib/lua/5.3/r/lib/r/init.lua’

no file ‘/usr/share/lua/5.3/r/lib/r.lua’

no file ‘/usr/share/lua/5.3/r/lib/r/init.lua’

no file ‘./r/lib/r.lua’

no file ‘./r/lib/r/init.lua’

no file ‘/usr/local/lib/lua/5.3/r/lib/r.so’

no file ‘/usr/lib/arm-linux-gnueabihf/lua/5.3/r/lib/r.so’

no file ‘/usr/lib/lua/5.3/r/lib/r.so’

no file ‘/usr/local/lib/lua/5.3/loadall.so’

no file ‘./r/lib/r.so’

stack traceback:

/home/we/norns/lua/core/norns.lua:136: in function </home/we/norns/lua/core/norns.lua:136>

[C]: in function ‘require’

/home/we/dust/code/torii/torii.lua:41: in main chunk

[C]: in function ‘dofile’

/home/we/norns/lua/core/script.lua:172: in function </home/we/norns/lua/core/script.lua:172>

[C]: in function ‘xpcall’

/home/we/norns/lua/core/norns.lua:137: in field ‘try’

/home/we/norns/lua/core/script.lua:172: in function ‘core/script.load’

/home/we/norns/lua/core/menu/preview.lua:21: in function ‘core/menu/preview.key’

/home/we/norns/lua/core/menu.lua:139: in function </home/we/norns/lua/core/menu.lua:116>

script clear

thank you for any help!

sounds like you need to install the R engine.

2 Likes

Also, make sure it is installed in dust/code/r folder, otherwise the require command will still fail.

2 Likes