Trying to update Teletype to 2.1 - Help Appreciated


#1

Connecting the Teletype via usb to either my Win 10 PC or a spare with Win 7 is proving difficult.
I hold the front panel button while powering on - and nothing, at least neither PC senses the device.
The Teletype screen remains blank.

What to try next?


#2

try a different USB A-A cable. cables labeled as “transfer” cables won’t work. i also had a problem with a USB 3 cable, while USB 2 worked.


#3

Also try it with Teletype being the only module plugged into your power supply. I have found this to be the best practice for running updates.


#4

I have upgraded/downgraded/upgraded several times since I got my TT last week.

At no point did my PC acknowledge the TT was plugged in and the TT screen was blank.

I just continued with the procedure. The write command appeared to work (progress bar on PC etc) and then a few seconds after the ‘start’ command, the TT came to life displaying the correct firmware. I then had to power cycle to get the keyboard to work.

Have you tried actually executing the command line instructions as per the guide?


#5

Same here as @rikrak regarding success, except I’ve done this now more than a dozen times with similar results.

As far as the suggestion to have it as the only thing plugged into your power supply, with over 100 modules in my rack this would be impossible for me to accomplish for as often as I’ve updated my TT firmware.

When I first got my TT I marked the USB cable with a piece of tape and wrote on it “Monome” so I wouldn’t get it confused with another short black USB cable :wink:


#6

Curious. Does it show up at all on your Windows Device Manager?


#7

Yes but not when I first connected the TT to my PC, which was when the instructions suggested it would.

Once tbe firmware had finished updating however, I checked again and the new Dev Mgr entry was there.

EDIT: I’m on Windows 10, for my sins.


#8

Thanks very much for getting back. It’s late - so I’ll have a review tomorrow


#9

Ran DFU programmer and got libusb0.dll error
Fixed that (I assume) as the next run gave a ‘no device’ error

Checked lead by taking the A - A lead and connected a A socket to type B - then plugging A side into PC and the B into some device. Nothing.

Used a normal A - B lead and the device came up on the computer - so suspect the A - A lead I have is a dud

Got an A - A (not transfer lead) on order


#10

I connected my A-A lead via a Mac keyboard’s onboard usb hub. I doubt that will help in this instance. Keep us posted.


#11

When you power cycle your modular system make sure that the USB A-A cable is not connected.

Sequence of events should be:

  1. Disconnect all USB cables
  2. Power off modular
  3. Count to 10
  4. Hold button down, and power up
  5. Connect USB A-A cable

Also, and this is on Linux but may also apply elsewhere, I’ve had unreliable results when using USB 3.0 ports on my computer. Try using USB 2.0 ports.


#12

sam - tried that - no hint on either PC (win10 & win7) and running dfu programmer just says no device

any way new A _ A lead arrived today, and when plugging now get a usb windows message (on both) saying windows doesn’t recognise the usb device

so went through the process of installing driver within the dfu 0.7.2 programmer directory, the ‘atmel_usb_dfu.inf’ but windows gives up with a ‘the folder you specified doesn’t contain a compatible software driver for your device. If the folder contains a driver, maker sure it is designed to work with Windows for x64-based systems’

Ah! do I need to be a 32 bit OS here?

Teletype is the only connected module.


#13

Well I got there!

installed XP on a spare disk. (note did not work with WinXP SP1 or WinXP SP3)

connected via usb no problem.

ran dfu-programmer

all worked fine

I’ll keep that disk handy for any future updates etc.
shall get one of these

then dead easy to switch in / out

thanks for your help - any ideas on Win 7 / 10 might be worth checking? But it worked so well under XP I’m happy to stay with that