TT: EVERY, SKIP, OTHER odd behavior [solved]

Hi all!
A weeks new TT owner/user here. Out of box I had fw1.2, so I finally updated to 2.1 and really started to dig into making some cool stuff.

I’m seeing an unexpected behavior with EVERY, SKIP, and OTHER though.
#8 (ext clock patched to IN 8)
EVERY 3: TR.P 1
SKIP 5: TR.P 2
OTHER: TR.P 3

What I’m seeing happen is at some number of repeats (it’s not consistent), one or more of the E, S, O will drop. In fact, watching the LEDs on the TR outputs, I will actually see the dropped ‘trigger’ will be very low lit… almost like the pulse time is getting ultra short.

The values for E/S don’t seem to matter, it will still occur. It almost sounds like a counter reset, but the TR LEDs getting dimmer is a weird indicator.

I must admit to having not tried putting this in the M script instead of driving from an ext. clock, but, I did not see any real change to behavior with a slow vs fast clock.

Thanks for any suggestions / explanations!

I’d say give the internal M-triggering a shot. I’ve found some variance in external triggers myself. Narrowing the scope would be helpful. I’d also say try a simple x counter (x + x 1) on that input and poll x in live mode right after every external trigger, to see if the external source is being read by TT as a burst.

Thanks Dan! As I got things setup last night to try your suggestion I discovered the problem.

I had M 25 set in my scene.

I’m not sure why, cause that fast a metro was not needed, but it was indeed the cause of the spurious missed trigger(s). Just changing up to 50ms stopped it occurring. And I eventually moved it up to 125ms (all M is doing in the scene I’m working on is scanning and scaling PARAM into Y) and no problems at all.

2 Likes

great to hear it all worked out! that’s super strange, though. M 25 is the minimum value before the experimental range. if you can replicate it, I’d say it’s worth a bug request. (@sliderule, am I off-base?)

1 Like

What was in your metronome script? Did it also have an EVERY/SKIP?

I tested the following scene:

#I
M 25
L 1 4: TR.TIME I 10

#M
EVERY 10: TR.P 4

#1
EVERY 3: TR.P 1
SKIP 5: TR.P 2
OTHER: TR.P 3

I patched TR 4 to the SCRIPT 1 input, and it seemed to run successfully.

I’m curious as to what’s in your M script.

1 Like

Interesting, I wonder if it was because I was using an external clock to drive the script (would be script 1 in your example). My Metro actually didn’t have anything in it. And in fact, when I attempted to debug, I hopped over to a blank scene (which I realize now carries over the M value) and setup the same EVERY/SKIP/OTHER script and used the same external trigger.

The next sit down I have with the TT I’ll see if I can reproduce again, and try different trigger methods. Thanks for trying it out!

This is odd, because the metro script won’t run without a command in it. :confused:

Are there any other scripts in the scenes that cause issues?

That was the only one I could really recognize as having a problem, and like I mentioned, it was subtle. It actually made some interesting rhythmic variation.

I should have time later tonight to get back in front of the TT and try and repro again.