Ultomaton - Generative Effects Processor

thanks, triggering play actions wiith the momentary/toggle params doesn’t seem to work for me…

True, this is not possible. The used mapping bpatcher only allows bindings to parameters, not to clips. You could always use another clip firing device … like this one:

Max Clip Launcher.amxd (51.4 KB)

select the desired clip slot and just map a toggle or momentary action to the launch button.

1 Like

Hi @ithkaa I had an idea about mutliple (4-6) inputs and possibly outputs. Was thinking of a 5 mic 5 speakers setup. Possible? Or run multiple instances of Ultomaton? Thanks

…and one more idea 2nd page on grid for the routing :slight_smile:

all good ideas … Already started working on v2 but the release won’t be anytime soon. I want to keep it as simple as possible (it’s somewhat confusing already) but will surely look into a multi-in/out solution …


I recently updated Ultomaton’s UI to be brighter and more clear in general. Download link in top post.

No changes on the inside… But… I started developing something else, based on the feedback I got here. check out this thread on the Upshot Suite: Upshot Suite - Max Package


How cool is this!! Thanks a massive lot.


Made these tracks using Ultomaton. Hope you enjoy! Really great for using it with audio directly from my laptop using Soundflower.


Just saw this thanks to the thread bumping and am investigating.

One minor question; is a Linux version ever likely to appear? Edit: seems to be working so far using WINE.

I get this message when trying to open the Mac version:

“Ultomaton 2.1” is damaged and can’t be opened. You should move it to the Trash.

Any thoughts?


This is a gatekeeper issue. Go to terminal and type sudo spctl –master-disable. You can enable it after you’ve opened the app: sudo spctl –master-enable

1 Like

So I do the first one, then open the app and then do the second one?

Do I need to exit terminal in between?


Don’t think you need to exit terminal. This would just enable gatekeeper again.

Ok. Do I need to do this each time I want to open the program?

I don’t think so but don’t know for sure… I never re-enabled gatekeeper

1 Like

@fahmi_m indeed, it is. check out this thread on the Upshot Suite: Upshot Suite - Max Package. I’m still developing this package so things are changing all the time.


having the same issue and tried this, but doesn’t seem to change anything. also tried a new unzip and redownloading and unzipping. any ideas?

try this: https://www.youtube.com/watch?v=6fqzb4qpgcs


I ran the code in Terminal but am still getting the message that the app is damaged and should be moved to the trash.

I got this in Terminal:

System Policy Basic Usage:
spctl --assess [–type type] [-v] path … # assessment
spctl --add [–type type] [–path|–requirement|–anchor|–hash] spec … # add rule(s)
spctl [–enable|–disable|–remove] [–type type] [–path|–requirement|–anchor|–hash|–rule] spec # change rule(s)
spctl --status | --master-enable | --master-disable # system master switch

Kernel Extension User Consent Usage:
spctl kext-consent ** Modifications only available in Recovery OS **
Print whether kernel extension user consent is enabled or disabled.
Enable requiring user consent for kernel extensions.
Disable requiring user consent for kernel extensions.
Insert a new Team Identifier into the list allowed to load kernel extensions without user consent.
Print the list of Team Identifiers allowed to load without user consent.
Remove a Team Identifier from the list allowed to load kernel extensions without user consent.
Eds-MacBook-Pro:~ edblomquist$