Ultomaton - Generative Effects Processor

This is a gatekeeper issue. Go to terminal and type sudo spctl –master-disable. You can enable it after you’ve opened the app: sudo spctl –master-enable

1 Like

So I do the first one, then open the app and then do the second one?

Do I need to exit terminal in between?


Don’t think you need to exit terminal. This would just enable gatekeeper again.

Ok. Do I need to do this each time I want to open the program?

I don’t think so but don’t know for sure… I never re-enabled gatekeeper

1 Like

@fahmi_m indeed, it is. check out this thread on the Upshot Suite: Upshot Suite - Max Package. I’m still developing this package so things are changing all the time.


having the same issue and tried this, but doesn’t seem to change anything. also tried a new unzip and redownloading and unzipping. any ideas?

try this: https://www.youtube.com/watch?v=6fqzb4qpgcs


I ran the code in Terminal but am still getting the message that the app is damaged and should be moved to the trash.

I got this in Terminal:

System Policy Basic Usage:
spctl --assess [–type type] [-v] path … # assessment
spctl --add [–type type] [–path|–requirement|–anchor|–hash] spec … # add rule(s)
spctl [–enable|–disable|–remove] [–type type] [–path|–requirement|–anchor|–hash|–rule] spec # change rule(s)
spctl --status | --master-enable | --master-disable # system master switch

Kernel Extension User Consent Usage:
spctl kext-consent ** Modifications only available in Recovery OS **
Print whether kernel extension user consent is enabled or disabled.
Enable requiring user consent for kernel extensions.
Disable requiring user consent for kernel extensions.
Insert a new Team Identifier into the list allowed to load kernel extensions without user consent.
Print the list of Team Identifiers allowed to load without user consent.
Remove a Team Identifier from the list allowed to load kernel extensions without user consent.
Eds-MacBook-Pro:~ edblomquist$

did you try this out?

1 Like

great, that one worked thank you. looking forward to trying this out

1 Like

That worked, thanks!!!

I got the same error message, and the sudo terminal command didn’t fix it. I remembered to check settings and tick “Allow apps downloaded from anywhere” under the Security and Privacy tab, and it works now. This is probably an obvious one, but just in case anyone else gets the same error, this could be the reason.

1 Like

Hi @ithkaa is it possible to increase the ramp time >1sec. I am trying t achieve more linear fades. (M4L version) Thanks

@ithkaa sometimes attack detection on GoL works only sometimes – lots of times it just wont & im relying on that funtionality >> . any tip? threshold set small/tight - thanks!

… it depends on what instrument you’re playing. The incoming audio signal has to drop below a certain threshold before a new attack can be detected. Typically, percussive instruments are great for attack detection but f.i. vocals or string instruments not so much (unless some staccato is applied).

Anyway, I found that AD won’t trigger at all when the threshold is set to minimum so I fixed that. You can find the updated MacOS app on Github (don’t have a Windows machine here … will update that version later).

ah, makes sense. and thanks for the little update too.
i appreciate this, and all your work as a whole Ben!

1 Like

Hey has anyone had an issue on MacOS Catalina where the actual window for Ultomaton doesn’t show up? The App starts fine but the window is nowhere to be seen. Thanks!

Happened to me too. I don’t know why this happens but the latest version seems to start up fine. I’m on a MBP 15’’ late 2013 (10.15.5) and have to wait about 30’’ for the app window to pop up.