Updating TLS certs on Norns, for things like curl & wget

I’ve been messing around with curling stuff onto Norns, and am finding that the distro’s version of curl has a slightly-outdated certificate store. Many URLs aren’t a problem, but sites with shorter-lived certs like Let’s Encrypt throw an error.

For example:

~ $ curl https://commons.wikimedia.org
curl: (60) SSL certificate problem: certificate has expired
More details here: https://curl.haxx.se/docs/sslcerts.html

There are a few ways to resolve this for myself, but I’m wondering whether it’s worth updating certs generally for Norns users, since it’s kind of a confusing error. On one hand, short-lived certs are becoming more common. On the other hand, it’s several years into Norns and I’m the first to ask about this, so maybe it’s just me.

1 Like