USB-C + High Sierra + 2016 MBP success

A lot of problems and uncertainly using monomes on various releases of macOS over here, but wanted to say that my monome works well with Apple’s USB-C to USB converter, High Sierra 10.13, and the FTDIUSBSerialDriver_v2_4_2.dmg

I’m not sure if this is necessary or not, but I did create and disable the network interfaces as per this thread

This is one of the newer 2016 MBP’s, 13" MacBookPro14,1 and I was worried about the USB-C dongles not working.

Cheers

3 Likes

It comes back online after and unplug and replug, which is great (and the main problem in that other thread!)

Thanks, this was helpful for me :slight_smile:

That FTDI driver is here, in case anyone else winds up looking for it again: http://www.ftdichip.com/Drivers/VCP.htm

MBP 2016 - OS 10.13
Tried to reinstall Serialosc and FTDI drivers but not working…
Help!

check the setup docs: you shouldn’t use the external ftdi driver on macos >=10.12. the builtin apple ftdi driver is all you need.

I tried also with builtin apple FTDI but doesn’t work. The strange thing is that when I launche de max monome package it says “if you haven’t yet, be sure to install serialosc”.
I installed it several times…

  1. check activity monitor, do you see serialosc? (if so, serialosc is installed)
  2. after plugging in, open a terminal, type ls /dev/tty.usb* do you see your device? (if so, ftdi is fine)
  3. open system profiler, check is monome device is present under usb devices
  1. YES
  2. YES
  3. YES
    but when I open for example Max7 monome package and click “launch” appear a popup:

ok-- so the monome package needs improvement.

the popup is just a reminder, not some indicator of something not working.

open test_grid and see if it’s working

1 Like

no…

@tomme - with your grid/arc device connected to your MBP what does the output from running the command kextstat -l | grep -i ftdi in the terminal show?

…if that command doesn’t produce at least one line like the following (for the case of the Apple FTDI driver):

  196    0 0xffffff7f84369000 0x3000     0x3000     com.apple.driver.AppleUSBFTDI (6.0.0) 4AB9F7CD-9185-32E6-8471-053EB5E81C35 <195 151 21 5 4 3 1>

…then it is likely that the FTDI driver isn’t getting loaded. I might double check the cables

I personally have found macOS 10.13 along w/ the built in Apple FTDI drivers to be reliable on both a 2013 MP and a late 2016 MBP w/ USB-C to USB adaptor. The devices I have working are 2012 arc2 grid 128 and 2016 arc4.

1 Like

im dealing with the exact same problem

1 Like

moving up to 10.13 now

2 Likes

Things definitely didn’t work with the builtin driver on 10.13 for me

1 Like

Im getting the same thing High Sierra, Early 2015 MB, Monome Grayscale, device appears in terminal,
Device not appearing in mark eats sequencer app or any max patches help please :slight_smile:

1 Like

Second this.
I have a fresh install of high sierra on a mid 2014 MBP 13" with an old walnut Monome 128 on which I did the bus power mod. The monome is showing up in terminal (/dev/tty.usbserial-m128_100) but no go in max or Mark eats.

I think it’s a serialosc thing, but not sure how to test:

The 1.4 pkg seemed to install the serialosc binaries here: /Library/Application Support/Monome/serialosc.bundle/Contents/MacOS

And homebrew installs them here: /usr/local/Cellar/serialosc/1.4/bin
Homebrew version just crashes every time I try to run it though, so… no idea. (segfault 11)

I’ve uninstalled and stopped the pkg installed one and am now fiddling with homebrew, but would love advice. Thanks!

I have now uninstalled and reinstalled both ftdi and serial osc, and installed them in multiple combiantions and each one alone without any results, full ssd sytem fyi, is there any possibility of serialosc being updated? Or should we just roll back, My system wasd working with Sierra but high sierra Monome cannot be seen

this is a clue. there didn’t use to be underscores in the device name, which is required for serialosc detection.

this of course makes no sense that some people have things working fine.

i’ll put together a further test for people to try, in about an hour once i grab an older unit

That’s hugely appreciated, thank you.

Not sure if this helps, but here’s what system report gives me:

monome128:

Product ID: 0x6001
Vendor ID: 0x0403 (Future Technology Devices International Limited)
Version: 6.00
Serial Number: m128-100
Speed: Up to 12 Mb/sec
Manufacturer: monome
Location ID: 0x14200000 / 11
Current Available (mA): 500
Current Required (mA): 0
Extra Operating Current (mA): 0