Using a Grid as Linnstrument

@AJG @Prnts what did you do to fix that issue? Maybe I can add some extra steps and details on this in the guide up on top.

Had to update the the Xcode command line tools.

xcode-select --install

Restart terminal after the install and then everything should be good.

By the way just got around to checking this out with Ableton and its awesome. How hard would it be to make a version that can be used for the drum rack?


Very easy, I’ll open an issue about that and implement that change when I get back home, I’m currently traveling for the next 4 days(without my grid).
Stay tuned!

How would you like for it to work?

  • Would something like holding a two keys to change octaves work?

That would be a good way to move through the rack I think yes.

The main issue using this linn patch now is that not all of the notes are available to trigger the 8x8 in a drum rack. It would be pretty cool if the left side of the grid was allocated to the active 8x8 in the drum rack granted this is obviously much different than the linn setup

I can’t do that without ruining the elegant layout of the Linnstrument, but, would you like me to make you a custom layout that is explicitly for doing pads and drums?

Draw a picture of which keys you’d like on the grid and I will make you a script for it! :slight_smile:

1 Like

Such a great idea!
Any chance that this could be adapted for a 64 grid? I tried running the script on mine, and it does work, but there are a few repeating and out of place notes on each row. Thanks in advance

I can try, but I don’t have one to test so it might a bit of a trial and error. You might be able to simply edit the list here to make it fit your device :slight_smile:

This range of notes would cover 4 banks of 8x8 in an Ableton drum rack. If you set two buttons for moving up and down the octaves like you said it should work pretty nice

34%20PM 43%20PM 55%20PM 11%20PM

On it :slight_smile: Give me a day or two.

1 Like

Niceeeeee thanks no rush at all. Extremely grateful. Will make my grid even more valuable when traveling

I had some time this morning, give this a spin.
Let me know what you think!


G0#  A0   A0#  B0   E3   F3   F3#  G3   C6   C6#  D6   D6#  CY   CY#  DY   DY#   
E0   F0   F0#  G0   C3   C3#  D3   D3#  G5#  A5   A5#  B5   E8   F8   F8#  G8   
C0   C0#  D0   D0#  G2#  A2   A2#  B2   E5   F5   F5#  G5   C8   C8#  D8   D8# 
GZ#  AZ   AZ#  BZ   E2   F2   F2#  G2   C5   C5#  D5   D5#  G7#  A7   A7#  B7  
EZ   FZ   FZ#  GZ   C2   C2#  D2   D2#  G4#  A4   A4#  B4   E7   F7   F7#  G7  
CZ   CZ#  DZ   DZ#  G1#  A1   A1#  B1   E4   F4   F4#  G4   C7   C7#  D7   D7# 
GY#  AY   AY#  BY   E1   F1   F1#  G1   C4   C4#  D4   D4#  G6#  A6   A6#  B6  
EY   FY   FY#  GY   C1   C1#  D1   D1#  G3#  A3   A3#  B3   E6   F6   F6#  G6  

So, 00 05 0A 0F would draw:

getting an error in terminal when trying

sudo npm install

seems to be a permissions issue

gyp ERR! stack Error: EACCES: permission denied, mkdir '/Users/prnts/Documents/rack/node_modules/midi/build'
gyp ERR! System Darwin 18.6.0
gyp ERR! command "/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /Users/prnts/Documents/rack/node_modules/midi
gyp ERR! node -v v10.16.0
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok 
npm ERR! errno 1
npm ERR! midi@0.9.5 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the midi@0.9.5 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/prnts/.npm/_logs/2019-07-12T02_44_16_516Z-debug.log```

That’s weird, did you had this issue as well with the linnstrument?
Could you try sudo again?

No problems with linnstrument all went smoothly when I did the npm install

Does it work if you don’t use sudo?

20 characters of no after just trying npm install

I’m not sure why your computer won’t give you permissions to install this. Let’s see if someone else has that issue as I cannot reproduce it.

I have a hunch that it may be an issue with the virtual modular program rack being installed. I’m going to try something.

**edit that wasn’t it. Tried on another machine which actually had a problem due to what I had mentioned above but it is still an issue on my main computer. So strange.

Apparently when I had installed linn I had made a mistake and installed to my home directory instead of the documents folder. So when I had just tried to to the rack install in the home folder it worked. Geez

1 Like

Happy to hear!
I’ve created a new thread dedicated to Rack.

Hey, I have finally had a chance to try out the linnstrument on a non-vari brightness monome. Thing’s look great. I only see the C notes, but that’s absolutely fine. That basically gives enough of a footprint to be able to use it.

Sorry it took me so damn long to try it out. Lots of work and travel, followed by brief stints fooling with the norns.

1 Like