W/ Firmware Update (v1.2.1)

thx for all your hard work.

I used the original firmware and set up an entire live set around w/ some weeks ago. I think even initially looping was pretty good but now I’ve had no real issues. However, the stuck in loop bug happened between sound check and the performance (which, from rehearsal i had been expecting), so I had to do a quick reboot/tape clear prior to getting started. Because i was preparing all the loops live it didn’t matter about existing cue points etc as long as I had a clear tape (or section of tape). I think the biggest risk was getting the loop points right which would be the case for all firmware unless w/type entering cue points is supported. anyway, my point being, go for it - you have a couple of months to learn how to manage any bugs but also these will likely not be there anyway. Also, the bugs in the other modes don’t seem to transfer to looping mode uses.

3 posts were merged into an existing topic: ~ Help W/ ~

Do you know if these issues were introduced in beta7? Was this functionality working correctly with beta6? Do these issues arise if you’re not at the very beginning of the tape (try adding some cues before making your recording)?

Can you try redownloading the firmware? There was an issue that @its_your_bedtime helped catch in the first 10mins of posting & i just switched out the file so as to avoid an extra point release. I think you may have grabbed the initial ‘always izzy’ version.

Again, can you confirm this is new since b7?

This is surprising to me. Does it always start at the beginning of the first (loop-left) tape as well? W/ should remember which cue point you were at when powering down.

Posting audio clips would be very helpful for these glitches as it’s hard for me to know what that means. Could mean dropouts, wrong-data, missed frames etc.

1 Like

Yep, it always starts at the beginning of first tape.
I’ll post audio examples when i get home

short piece recorded on beta 6

I hear the clicks at several points, is it just the nature of the wave not being auto-corrected, accurately edit/matched/looped with the toggle edits? or is something else putting the clicks there electronically?

I downloaded B7 again and it was 5KB larger than the first B7 that I downloaded.

Installed it and verified that the glitches and That playback were both still issues on this newer B7.

Downgraded to B6 and the glitches were there all the time but from whatever I’d been recording before I guess it didn’t really stand out.

B6 also lets me play back and forth the tape with That to my heart’s content.

Strangely although I had the earlier B7 I didn’t have issue with Izzy returning.

Sounds like it’s been recorded on the tape that way (the dropout occurs at the exact same place). Is the dropout at the loop point, or elsewhere within the loop?

I’d like to view it in a sample editor (so I can see exactly how long those gaps are). Is there any way I can download that audio file without making a Clyp account?

Starting at the beginning of the 1st tape every time makes more sense than only one or the other. I’ll investigate the metadata saving further.

You mention you didn’t get Izzy. Does that mean your tape-selection & cue-point are being saved between power cycles?

Sounds like the glitches are happening when recording, so you’ll need to record new material after downgrading to confirm functionality. Does anyone know how far back you have to go for the glitches to stop?

That was a longer piece initially, i’ve just looped corrupted fragment, other part of recorded material was ok

I’ve not progressed past a single tape yet in my playing with W/. As for cue-points on B7 they are not being saved. I just reinstalled B7 for the third or fourth time today and still no Izzy.

I went back to B3 and B4 (was testing B6 earlier) and all of them are glitching. My sense/feeling is that B3 was not as glitchy as B7, but that’s not 100% certain. I do not have B1 and B2 to test with, though I see I could download them if I were so inclined.

1 Like

Loving me the B1 firmware as I’ve made three recordings without 1 glitch.

Do you mean no cue points are being saved, or just that your place in the cuepoints is not saved? If no cuepoints are saved at all that’s a big regression!

Regarding the glitches, I’m very surprised to hear B3 also has the issue and yet noone has mentioned it in this thread? I wonder if there is something we’re missing here?

When you went back to B3, can I confirm you recorded a new loop, not just playing back an existing one?


For those experiencing glitches, can you write a little about your experience:

  • How often does the glitch occur? Is it regular, or intermittent?
  • Do the glitches occur at loop points?
  • Are you always making recordings in the same way (eg: recording, then down + up to set a loop?)

Oh sorry about that…cue-points are certainly being saved, just my place in them.

Every time I install a new or old firmware I reboot with a down arrow and record press to ensure I’m starting with a blank tape. Like I said, B1 is totally clean. I’ve not tried B2.

For my experience with the glitches I’m starting with a clean tape.
I add three cue-points to the start of the tape.
I press record and then play.
I do not add cue-points or loop at this time, I just record for about 45 seconds.
The glitches are not typically on a cycle or predictable. They can happen in the first 10 seconds or after 30 seconds. They can happen twice in that time or 5/6 times.

An audio recording would be beneficial if that’s possible!

1 Like

I’ll test Beta 7 soon, but as regards my mention of clicks earlier (for Beta 6), it seemed clear to me (although I didn’t check) that the glitch was consistently at the loop point and since it got softer with more LIVE.THAT CV, I assumed it meant the recorded audio was wrong on one (or few) samples, creating a discontinuity in the recorded waveform dependent on its amplitude. The clicking did not occur if the input was silent, and it did not occur in the monitored “dry” signal.

I believe these are 2 separate issues. There are clicks at the cue points & this has been improved but does remain in some small amount. The click is emphasized when recording in one direction, then playing back in the opposite direction. The cause of this issue is known, I just haven’t got to a fix yet.

The gaps in recording that @its_your_bedtime and @unity2k have reported appears to be a new issue to me. I haven’t heard about these random gaps in recording until this point. If people have been experiencing them along the way I’d be curious to hear. Also, please send in more reports if anyone else experiences these.

As always it’s really great if you can explicitly say which beta you were using before the upgrade, and confirm that the issue wasn’t present on that previous firmware. I know it gets repetitive, but it helps me so much when people are overly clear about their experience.


Beta7 again after sending you the recording. If after recording and while in NAV mode I hit the Up arrow to fast forward I can no longer play a tape and have to reboot. Happens every time regardless if I don’t have a cue-point at the front of an empty tape or I place three cue-points before I start recording.

I experienced this same issue (I had no cue points on the tape).

I also had the same issues described above with the recording cutting in and out using a clean sine.

Edited to add: I experienced neither prior to beta7.

Good news: I am no longer stuck in tutorial after flashing the newer beta7 :slight_smile:

1 Like