W/ Firmware Update (v1.2.1)

This probably belongs in some self-help thread elsewhere, but my issue with reporting stuff is that I think 97% of my issues are caused by my own ineptitude and that the reason so few are speaking up is that they are all having a great experience while me the troglodyte can’t get the brain cells together to know the basics. I wonder how many other people think their issues are operator issues and not firmware?

1 Like

Beta7: I am starting on tape 1 regardless of the active tape on shutdown. This happens regardless of state (I haven’t shut down in cue).

I had a few drop-outs in beta 4 that i didn’t mention as I suspected (and still suspect) that they were down to my own sloppiness :hugs:

I am trying to replicate what you did in beta 7 now. With material recorded and having moved to the beginning of the tape:

  1. I hit play for a sec. Hit play again to disengage. The tape is stopped. Orange light over the switch is lit.

  2. Hold up to fast forward. I can hear it starting to zip along (most times) and then the sound cuts out. White light over play lit while fast forwarding, light goes out when sound cuts out.

  3. Hitting play now does nothing. No sound, no lights (other than orange light over the switch)

  4. If I hit Loop, both lights over loop engage. I can toggle between both lit or just orange. I can also toggle record and the white record light turns on/off.

  5. Hitting play with loop engaged now turns the white light over the switch on and off, but it does not play. If both loop lights are lit, play turns the white light over switch on and it stays on. If only orange is lit, hitting play causes the white light over switch to briefly illuminate

  6. With orange light above switch on and white light over switch off, and only orange light over loop on, it will allow me to rewind. Play now functions again.

  7. With (same as in 6 except) both lights over loop engaged, it will let me rewind and play, and functions as expected.

  8. With (same as in 7) except white light over switch turned on by toggling play, i cannot rewind or do much of anything.

The time fastforwarding in NAV before it crashes seems to vary a bit, from no time to 1 or 2 seconds up to approx 10 seconds. It hasn’t forced me to reboot as of yet; rewinding has brought back play each time so far.


3 posts were merged into an existing topic: ~ Help W/ ~

Beta 7: i am slso starting up on tape 1 everytime

Getting the dreaded loud glitch pattern when moving between modes with triggers patched to THIS and cv fom cold mac to THAT.

2 posts were merged into an existing topic: ~ Help W/ ~

2 posts were merged into an existing topic: ~ Help W/ ~

So, what’s the current status?
It seems like it’s been nearly two weeks since the latest beta iteration…

The current status is reflected in the first post :slightly_smiling_face:. Seems like we’ve found a number of bugs that are being worked on. No new bugs in a few weeks is definitely a good sign :slightly_smiling_face:


I understand your approach to this situation, but since the last beta there were still several new reports and no confirmation that those bugs are worked on. Plus, with all this bugs that creep back in (such as the aliasing) I’m still unsure whether my unit is working as it should, or i am experiencing a bug or I’m too stupid. I find this situation rather frustrating. especially since it is our for several months now. no constructive addition from my side to the thread, I guess.

1 Like

For me, it seems like 1.0.1 is the most stable version (except freeze bug)
Since bug with sd driver was fixed in beta 6, maybe we could get 1.0.1 with fixed driver?
Kind of hotfix for 1.0.1, so most people could use module without problems while the development is going

There is work being done on it as @Galapagoose has pm’d me recently about one of my bug reports he’s obviously working through.

To say the there have been, “No constructive additions” is a bit harsh because I’m one of the first buyers of the W/ and I avoided using it until the first beta firmwares started showing up and since then there have been huge improvements.

How about instead of making non-constructive statements you grab beta 7 and start testing it and make a report about what you find?

There seems to be a misunderstanding. I meant: I have no constructive comments to add - sorry. I edited my initial comment.

But good to know, that @Galapagoose is still working his way through the code :slight_smile:

1 Like

beta8 up top!

There’s only 1 fix here, and it unfortunately brings a regression:

  • FIX Tape-selection, and last-cue-location are now saved between powercycles
  • REGRESSION Tape-selection causes a small audio discontinuity

Otherwise this update is focused on low-level improvements. I won’t go into finer details, but on the user side this should mean no more clicks in recordings. CPU usage is dramatically reduced and loop-point clicks should be reduced as well.

Thanks again for your patience. Feels like we’re getting close!


Can confirm, also manual playback via THAT seems to malfunction

The CV control of overdub/overwrite uses CV into that!

sorry…your right. got confused by NAV mode. Thanks.

I have seen an issue where CV stopped working at all, but I believe it’s fixed. Do let me know if you have trouble getting CV to be recognized. Easiest way to check is CV->THAT in NAV mode to control the tape speed.

yes…just checked. sometimes it works (in THAT) sometimes not. restart helps to make it work again.
couldn’t figure exactly way or what steps but will pay attention.

not for me. CV to THAT in NAV works but not in PLAY for overdub/write.
also having problems with loop on/off (could be user error)
but in general, working since the release with the original firmware, i feel much more lost now with beta 8.