W/ Firmware Update (v1.2.1)

There are still some free key combos on boot :upside_down_face:

well how is it everyone, better than the original so far?? or should we just wait until its official and not “beta”?

The beta has been well-behaved so far, with a blank tape. But then it was often okay before too with a blank tape – I’d have to use it more to say it’s all taken care of.

Unless you really loved the aliasing or have content on your tapes that you don’t want to potentially lose (and are confident the current version won’t lose it anyway) I’d say there’s probably little risk in trying the beta.

i did it anyways, and i cant even tell if its buggy or not because i still dont know how to use it properly

i did notice that it said when updating it would do the animation only 4 times but mine did the animation like 6+ times, should i be alarmed by that?

So after a few hours using the beta I’ve not encountered any of the bugs I had before. No more rebooting for me. I have not yet gone into cue mode, but for me nav and play are behaving very well.

Great work @Galapagoose! Thank you for taking the time to properly address the issues.


I wouldn’t be. Same here on installation, and all seems good.

it’d be cool to bring back aliasing. we wouldn’t have that beautiful @MengQiMusic video without it :slight_smile:


Just ran into a potential issue after exiting cue mode.

Situation: I was in cue mode, added a new cue and went back to play. The light above ‘loop’ stayed white and I could no longer turn on/off the looping. Only way to get it back was to reset.

So far Cue mode is the only mode that has caused issues with the beta firmware. Nav and Play work like a charm.

@Galapagoose I’ll let you know when I’ve got the exact steps that caused it.

1 Like

Been playing around with the beta for a while now. Definitely seems far more stable. Thanks @Galapagoose!

1 Like

If you can find a series of steps to repro that particular behaviour I’d be incredibly grateful. I spent many many hours trying to reproduce that exact behaviour to no avail, it always seemed so random to me when it would occur.

Has anyone been having issues with the ‘glitch’ sound appearing on their tapes? I think that’s been ironed out, but want to make sure!

Regarding the aliasing, it may be interesting to note I had the interpolation coefficients back-to-front for above 1x speed recording. It was super broken (and technically not really ‘aliasing’)! Made everyone sound the same. Now it sounds like you. If you want aliasing just use the tape at <1x speed! I’ve been experimenting around 4% speed (0.1v to THAT in NAV) and it’s glorious!


Installed beta fw, recorded and moved through cues and ff rw through points, everything feels flawless, tighter. The character of the sound wasnt really lost with the improved quality imo.

Cue mode is still causing trouble, just got the cant move between cues crash. Here’s what I was doing before it happened:

I recorded and looped some audio.
I wasn’t satisfied with it, so I overdub recorded it into silence.
Then I decided I wanted to delete the cue point at the end of the loop, so that when I made a new recording I would flick up at a new/different end point.
I entered cue mode and fast forwarded towards the end of the loop, hoping to eventually see a yellow light over record and press R to delete the endpoint.
As I got closer to the end(white light getting brighter) I over shot the end and tried to rewind back. I exited cue mode to make sure I was in the same sound space and now loop movement is completely unresponsive.

Additionally, I was playing with a tonal sample in cue mode sequencing with Rene and mistakenly tthopught that I could change the octave of playback by pressing play and up, like in live mode. This seemed to cause a stepped change in volume to the sample. Strange.

Just updated. I haven’t had a chance to play with it yet but that intermittent animation looked great, made me realise how nice those little leds are, don’t think I’ve seen anything else in euro that looks like that. I forget how beautiful w/ is because it’s so tiny. Will report back after some testing. Thanks again

1 Like

I got the “stuck in a short loop” error quite quickly just flicking up and down, x2 and half time while recording in live mode. I had to abandon it at that point because I was working on other things. Usually I would restart/clear the tape.

Will the I2C protocol be released so as we can use W/ with another device such as arduino?

I2C is already released as a protocol in general. in specific, the W/ Type commands will be / are part of the Teletype firmware, which is already open source.

1 Like

I think I’ve managed to recreate a bug 3 times now. Started with a blank tape, plugged in a signal, monitoring is fine, pressed play and let it roll a little, then pressed record, then down let it run for a while, then up, nothing was recorded and even rewinding and trying to record at any point doesn’t record, mornitoring is fine during all this. All the lights are doing what they should during this. A reboot seems required to resume recording ability. I’ve gotten this twice from a blank tape and once from a tape with some stuff on it. Other than that it does seem much more stable.

Same bug happened to me during my show yesterday. :pensive: I’m going to see if I can recreate this at all. Otherwise I’ve had nothing but good news from this update. Will be happy for clickless looping!

Had you cleared the tape since installing the beta firmware?

To confirm: you are in LIVE mode, currently recording(overdub or overwrite?), then alternate between play+up & play+down to cause the short-loop error? How many times do you need to flick the switch (ballpark number)?

@HateNames & @geh2oman
You say you’ve recreated the bug 3 times. Is this 3 consecutive times, or is it intermittent, but you’ve seen it 3 times in total. If it’s intermittent, how often does the bug occur?

Does recording work fine if you don’t add cues while playing back?

Assuming recording generally works, If you only add cues (with down), but don’t set a loop-end (with up), then manually loop after turning record off, does everything act as normal?

Hey @Galapagoose it’s intermittent. I’ve been using it for a few days and I’d say of all the actions/ reboots it’s happen maybe 1 in 10 times, sorry I can’t be more precise, most of the time I get lost in how great it is and lose track of what I’m doing. In terms of recording happening I hadn’t tried it with no cues from a fresh tape but when it has happened It’s been playing from the start of a blank tape, monitoring input, then I’ve pressed record, and after that added a cue, then another cue to loop, and that’s when I notice that nothing has been recorded, when I rewind nothing has been recorded before the initial cue either, the tape has still been blank. Once it has gotten into this state I tried recording a few times and even though the lights were all doing what they should, nothing records and a reboot is required and then works fine. I didn’t try deleting cues when I get that bug I’m afraid. Next time it happens I’ll try that and report back. Thanks again.

I haven’t played with the new firmware long enough to repeat this, but I just encountered the same error. Hit play, rolled some space, hit record, down, and up. Nothing was recorded and a reboot was required.

On reboot, the unit was on the section of tape it had been on when booting the time before (I had moved many cue points ahead before needing to reboot). I recorded without error.