W/ Firmware Update (v1.2.1)


#413

Without the harsh words, I do often get crackles over the sounds I record too. I got my W/ secondhand and I think the previous owner had the initial firmware on it when I got it and I think this didn’t happen at the time (I updated it soon after getting the module though).

Any idea on what could cause this ? My sound sources are attenuated and this does not look like a headroom issue at all. I’m using an Intellijel 7U case with a beefy TPS80W supply, btw.


#414

Have you tried erasing the tape on startup?


#415

v1.2.1 is working flawlessly for me! I haven’t noticed any crackles… but I have been spending a lot of time with a Cocoquantus, so maybe i’m desensitized a bit lol.

I know this doesn’t really help with debugging, but I wanted to throw some positivity out there :sweat_smile:


#416

Although mine is working now, I do agree that it wasn’t ready for release when it first came out.

The first reason being it’s a cryptic module to begin with(at least when you first put it in your rack) and the bugs caused a ton of confusion as to whether it was user error or a bug.

Secondly I think the issues have left me forcing myself to remind myself that it works now. When patching I still sometimes skip it because my instinct tells me I don’t want to invest time in a patch that could potentially break any time(this is a leftover from when it was just released). I love it, but after months of bugs it’s going to take some time to adjust my mentality towards it.

That said, I’m very pleased that @Galapagoose has put a ton of effort in fixing the bugs and I think that, although it’s been a rocky ride, it’s a keeper.


#417

Hey everyone –

If anyone is having serious issues with a module, please do write to us at service@whimiscalraps.com, and we will be happy to help you get to the bottom of whatever may be wrong with it. We do not want anyone to have negative experiences with our modules - they are supposed to foster creativity, excitement and happiness, not frustration or sadness! We put a tremendous amount of work into them and really care about everyone having positive experiences with what we make. The journey with W/ has been bumpier than expected and we appreciate you all riding it out with us!

Regarding “crackling” with recording or playback - it’s something we have never seen or been able to reproduce, so if you are having this issue with “crackles” or distortion with recording/playback, can you please provide us with any more detailed information you have about it, and ideally any audio recordings you might be able to make of it? Is it intermittent? Is it on the input signal (i.e. if the tape is stopped and you have a sound source going in, can you hear it?), or is it only on tape playback? If so, is it present if you play back blank tape?

Recordings and more information would really help us get to the bottom of it, as we simply have not been able to make it happen or come across it in the wild (assuming that it is distinct from the digital noise that used to occur when updating to the early firmware beta versions if you did not clear the tape after executing the update).

What you are describing sounds different, but there’s a chance that the crackling you are hearing is the same as the digital distortion which came from the module accessing junk SD card data that was already on the tape, which is fixed by clearing the tape after a firmware update. From v1.2_rc0 and beyond, you do not need to clear tapes after a firmware update to avoid accessing bad SD data, however if you are having that issue currently, can you please try documenting it as best you can, and then clearing the tape to see if that fixes it?

If you have any more information on this, please shoot us an email - service@whimsicalraps.com.


#418

No accusations either direction intended here, just a question (I was not in the very first round, but the second trickle of modules released and was aware of the beta status):

Was the release firmware 1.0 beta?

I believe that the module was released in good faith, and that @Galapagoose would have preferred the primary release have no bugs. We do have to remember that our favorite module manufacturers are often companies of just one or two people, and things happen. Hell, half of your favorite manufacturers aren’t even able to do it and make a living from that alone.

Again, I don’t remember if it was released with the firmware publicly stated so being in beta. Maybe a batch that was very specifically in open beta/ a soft launch, could have helped alleviate some of the issues.


#419

The firmware it shiped with in March(initial release) was 1.0.

From what I can remember the first beta was released a couple of weeks later.

I feel sorry for the team as it must have been intense and stressful to see all the reports pop up just a few days after release. As to me it’s a module with bugs, but for them it’s their hard work and source of income.


#420

@voidstar Why not release the code as open source? I think there are a lot of smart people out the who are happy to support you.


#421

I think @Galapagoose has mentioned elsewhere that they intend to open-source it only when they feel it’s ready. Even @pichenettes waits until a modules development costs have been recouped before open-sourcing, and with only one proper batch sold, it’s unlikely that Mannequins is at that point.

Given the huge additions in version 1.2, it seems likely that there’s more vision in store for W/ before they “turn it loose”.


#422

Releasing the complete module, incl HW and SW will go way to far. I was talking about releasing only the code


#423

i just uploaded the new firmware and ran into a bug after a couple minutes. i’m in nav mode, feeding CV from a teletype pattern into THAT to control a loop’s play speed. if i feed it 8v, it that gets stuck at that level even if i feed it less voltage (it continues to play very fast even when i change the voltage to 1v, 2v, etc.). please let me know if i’m doing something wrong! if it’s not user error, hopefully this can get worked out in the next beta.

edit 1: power cycling brings it back to normal, but i keep running into the same issue.

edit 2: after a few power cycles, w/ is now unresponsive with the orange light about the switch and white lights above loop and play on. no sound is coming out.


#424

honestly i think its kinda rude to jump to open source as a solution to technical issues without explicit knowledge of the developers’ intention re licensing etc :man_shrugging:


#425

I think I cleared the tape once at some point but I’m not sure I did it after updating the last time. I still need to update to the latest though, so I’ll test that first and if I still have issues I’ll clear the tape and report what happens. I don’t have time with the modular every day though, as a couple of little human beings tend to monopolize my free time these days so it might take a few days to do that :slight_smile:.

Btw, I had to search this thread to find the info about how to clear a tape, that should probably be added to the manual…

Edit - about the crackles : they tend to happen especially at the loop point and are consistent from one play to the other, and I think I got more in the middle of the loop when layering over existing audio. I’ll try to record something before updating the firmware.


#426

So, how do you do it?
Why not repeat the instructions here.

(I agree with you that this should be in the manual. Along with: how do you get rid of Izzy, that keeps coming back after every restart, despite the fact that one completed the tutorial sequence…)


#427

Hold Record + Down on the toggle while powering up. This clears the currently selected tape.


#428

In fairness, how to clear a tape is in the top post on this thread, as well as on the “firmware update” page for W/ on the Mannequins site…


#429

i’m sending the email with the bug report, but here are steps to reproduce the bug 100% of the time, in case any one else wants to confirm the crackling audio in 1.2.1:

  1. setup a decaying delay/looper as seen in this post. with any kind of decent negative voltage, the audio crackles almost immediately. it also occasionally generates quiet pops, similar to hearing a cable plugged in/out of a mixer.

  2. now flip the play direction of the delay via teletype WS.PLAY, so the delay/looper is now playing in reverse. this results in an immediate loud pop, which might repeat itself occasionally. i think it might be happening right on the loop point.

it’s an awful, loud sound, especially if you have one w/ running into another, as i do (to build up unsynced delay washes), and controlling them with teletype via WS.PLAY commands.

this bug is a bit of a showstopper–i can live with the crackling audio that occurs at all levels of negative THAT voltage and forward play direction; i can work around it as ambient grit. but the loud pops in REV (and to some degree in FWD) mean i can’t use the realtime play direction changes in my upcoming show.


#430

It’s definitely not on the firmware update page on the Mannequins site. I have that one opened and checked it first…

I just reproduced the clicks/crackle using one attenuated droning output of Just Friends (at 20% to 50% of normal volume) into W/. I get a very audible click at the loop point and then get more crackles when layering sounds. As I said, these are already quite a bit attenuated using one channel of an Intellijel Quadratt and this should definitely not be an headroom issue…

I have no battery left in the handheld recorder I use for the modular but I’ll try to record the loop tomorrow or in a few days.


#431

And I just cleared the tape and tried the same experience again and I still get a loud enough click at the loop point and crackles when layering a very attenuated Just Friends. I got the same with a sine output from an STO.

I tried with some other modules and while I still got the audible click on the loop point (when looping a droning note) the crackles appear much less : Radio Music and Erica Pico VCO. I know that the Radio Music’s output is not very strong so that might actually be somehow volume/headroom related…


#432

Remove post please. Thanks