W/ Firmware Update (v1.2.1)

I have periodically same “stuck in loop/no rec” bugs, but it occurs only after module left in nav mode, not being used for some time (2-5min)
If i leave it playing, then it’s ok (kinda workaround :slight_smile:)

Can you be more specific here. I believe the ‘stuck in loop’ and ‘no recording’ bugs are 2 independent things. Do you experience both of them at once, or randomly one or the other?

When you leave the module in NAV mode for 2-5mins, is there anything attached to THIS or THAT?

When you do return to the module, can you describe the behaviour a bit more elaborately?

Has anyone seen these “no recording” bugs in any context other than in LIVE mode, pressing down then up?

Thanks for the detailed report. I will try and reproduce the “overshot” marker in CUE mode.
I will note however that in order to delete the end-point of a cue, you can’t fast forward from the start-marker of the loop. Instead you should enter the loop, confirm it with audition, then loop+up to select the next cue (which will be the end of the loop marker), then you can delete it directly by pressing record.

The play+up behaviour in CUE mode is certainly strange. I will try and repro.


Here is a short video I made yesterday reproducing the same glitch. The video begins with W/ booted with the clear tape function.

1 Like

Hehe, poor @Galapagoose is going to have to slow the speed of the vid down to 0.25 speed :innocent:

I think this has happend to me too, but I’m not sure if it is exactly the same. If I understand correct this is the glitch that stops looping from working, right?

@Galapagoose no I haven’t cleared the tape or switched tapes since firmware update.
Recording in overdub and yes I am just alternating between play + up and play + down. I only flicked it 5 - 10 times on this occasion. It is an issue persisting from before the update and there was not really any relationship between how many times play speed was changed and the getting stuck in the loop. Makes me think that it may be due to some subtle button/stick press combo. In any case, there’s no way of getting out of it once it starts

As mentioned in the top post, I believe weird issues like this might be related to a bad set of cue points being stored on your current tape. The firmware update will not fix previously broken data (because it’s near impossible to know in which particular way the data is incorrect).

If you’d like to help debug the firmware, could you perhaps switch to a new tape, clear that tape, then try to reproduce in that new context?

1 Like

Did a bit of this last night and all is working well so far.

I keep having the short/stuck in a loop problem whenever left on but unused for a period of time. This is on a fresh tape with only two cues on it.

By unused you mean, NAV mode & no CV attached?

Nothing but a patch cable in the output

1 Like

The same thing happend to me.
New tape, only cable in output, NAV mode, no CV attached. 6 cue points on tape.
Module gets stuck in a loop when left unused for 10-15 minutes.

I haven’t tried the beta, but this was/is common for me too. Just an output cable and after a while it goes wonky.

1 Like

I’ve spent whole day trying to catch theese bugs, but with clear tape it worked flawlessly!)
After i got, maybe, 30 cues, i’ve had stuck in loop issue, not sure exactly what was the reason.
All this low reproducubility makes me think that there is race condition hidden somewhere

Btw, also had an issue when after reboot it starts with first cue on tape, not last used one

Same here, it is alot more stable but I very occasionally get stuck in the loop - say 1 in 20 times (just a patch cable in the out) with multiple cues and have wipe the tape to start fresh again. Sometimes I get an issue where it’s left on a while (in Nav mode) and it doesn’t record the audio, just a click like it just recorded a button press then a blank space and noise at the end - this is with just a patch cable on the out. Btw - I wiped the tape before putting the beta firmware on.

1 Like

I’m also sometimes getting only very short snippets recorded instead of what I expected. In my case I don’t want to rule out user error just yet, since I just got the thing.

1 Like

I reproduced the stuck in loop thing yesterday. Only cable in output. Left the module unused for 20 min and when I wiped the tape before installing the beta firmware.
Tonight I will see if I can recreate it after wiping the tape again.

Thanks for the reports all.

I believe I have isolated the reason(s) for audio not being recording sometimes, and the loop button (and cue motion) not working after using CUE mode.

I’ll post a new beta this evening EST time. Hoping to have a fix for the above, but even if I can’t finish that I’ll post a new beta with a bunch of other smaller fixes, plus ‘delete-all-cues’ command (via global page).

Appreciate the patience & support :woman_mechanic:


Just came here to mention that the record bug where it only captures a snippet happened to me last night. Cant wait to try the new beta, thank you so much!

Hi All,
New beta posted on the firmware-update page. New changes listed in the first post. It’s certainly not perfect, but feels much better to me. I’ve been testing for very specific behaviour though, so appreciate any and all feedback. Many things could easily have been broken, so don’t be afraid to say old things have recurred.

This update doesn’t solve the fundamental problem which (i believe) has been causing the loop-command failures, and the no-recording. It does however make that situation much less likely. There’s still more to do, but I’m floating this beta to see if it’s ‘good enough’ until the next firmware update in a couple months.

The clicks on loop edges are not fixed yet, though we now have a good understanding of why it’s happening which is a strong first step.


mine do not restart after the file is finished playing. i did notice that this file is about 16 seconds shorter than the last beta file, is it possible that the beta2 file is not complete? sorry if im assuming too much