W/ Firmware Update (v1.2.1)


I think it may not have downloaded correctly for you? For me all of the firmwares are ~2:32 long. How long is the beta2 file for you? I just checked the website and it seems fine to me (though I’m at home now and haven’t tried to a flash a module with it).


you seem to be correct, i wonder what would have caused the download to cut off



Just downloaded the new FW, and switching tapes does not work for me. Pressing L in global mode does nothing. The 1 second hold to prompt cue clear does work.


Would it be possible to leave the old beta’s up on the download page also (dated - so it’s clear which one is newer/older), just in case this one doesn’t work out and I need to go back?


(edit: moved old betas to the Firmware Update page linked in the first post)

Thanks for the bug report on not being able to switch tapes. I definitely didn’t test that after adding the clear-cues command. Will fix tomorrow.


Had an instance of recording and getting nothing back on playback on this new firmware. I’m done with w/ for the foreseeable future. I’ve got 3 of them and have self built the i2c boards etc. I really bought into the idea but they are honestly just zero fun to use. One is always not working. I’m putting them in a drawer for 12 months and forgetting about them as I couldn’t sell them on with a clear conscience. Bad vibes.

Steps that caused the issue:

  • Install latest beta firmware
  • Clear the tape
  • Press play
  • Press record
  • Stop record
  • Rewind tape
  • Press play
  • Audio successfully plays back
  • Enjoy fleeting feeling of success similar to the lingering sparkle of an eroding afternoon daydream
  • Forward tape past successful recording
  • Press play
  • Press record to record new jam
  • Stop record
  • Rewind tape
  • No new recording but old one still there
  • Pull w/ from my rig

Case is a Pittsburgh 420. No power issues, all other digital modules working fine ( ER301 *2, Teletype x 2 etc. etc. )


beta3 updated on the page in the top post. All it fixes is the tape-select.

@burn. Sorry for your bad vibes. This thread is literally us trying to solve these problems! If a beta version not being perfect is going to be upsetting for you, then please wait until the official 1.1.

I do appreciate your bug report. It’s the first time anyone has documented that bug without using the down & up combo to set a loop while recording.


Just installed the latest beta, should have a chance to play around later today. Very thankful/excited for the progress made so far! Thanks @Galapagoose! (and team)


The best way I have found when looping and recording a new take, after the loop, is always use the up and down to set the loop. When I’ve finished messing about pitch shifting a loop or other manipulations, I hit the loop button to unloop, whilst play is running, and let the playhead pass the end of the loop (on the fly). Once past the end I start record+play+down again and set the next loop. That last beta was the first time I could do that without some issue.

Musically this is not anything special because what I’m trying to do is break w/ and I couldn’t. I record a bit, loop it, play about, unloop, let the playhead run past the end and rinse and repeat. Occasionally when trying to pitch up and down + play, i accidentally miss the play button and insert a cue to get micro loops but that’s operator error. The point of the video was that the firmware is definitely getting more stable as previously I couldn’t do this :slight_smile:


so there are three different versions of the beta now, correct??

1st wslash_1_1_0b.wav

2nd wslash_1_1_b2.wav

3rd wslash_1_1_b3.wav (newest)


I have a bit of a weird problem with the latest firmware. I changed to a new tape - and when I played was only able to hear a brief bit of my recording. I tried power cycling the module and now it shows no lights when I turn it on and doesn’t respond.

If I power on whilst holding the record button - it correctly loads into the state to recieve a firmware update, but I can’t find any other way to make it respond.

Anyone had a similar problem?


I had something like this and just tried reinstalling the new firmware. After 5 or so goes it took and has been fine since. I assumed ther may have been interruptions in the audio streaming…?


i had the same problem after i cleared the cues on a tape i made with the last beta. no problems after rebooting tho.


There’s a definite chance the clear-cues command is not working correctly. If you find this kind of weird behaviour, please try doing the full ‘erase’ (record + down while rebooting).

@jwhiles (or @yoyosandshoes) can you be more specific about what “a brief bit of my recording” is? It’s hard for me to get a sense of what this means. Did it start correctly, then drop out, or does it cut in/out? Did the ‘brief bit’ end after adding a cue or something?


Just updated to the latest beta, rebooted into Izzy (practice makes perfect) and got stuck: got to “now, rewind” and immediately flicked ‘down’ to start rewinding, but managed to rewind back into “hey, I’m stuck looping”. As soon as I stopped rewinding, the white play LED and the two above loop activated as expected, since now they’re looping, but the unit didn’t respond to my various tries until I did play + up, which let me get past the next prompt.

play + up didn’t let me pass “now, rewind”, but I think up + play might have? Pressing play in response to “press play” did work, however. The next prompt is reversed? But doesn’t play forwards in response down + play (nor to stopping the tape and pressing play again).

Tempted to try to see which command will let me pass… but instead let’s just reboot and try again.

ETA – the next play-through went totally fine.


Another bug? Similar to the above: I left the unit doing nothing in particular for a while after playing with it, then when I came back I pressed loop + up maybe six times to try and move past all my cues, but found that playback was stuck repeating a small chunk of a loop I’d recorded.

I believe (but cannot guarantee) that the tape was fresh.

The unit otherwise responded as expected to my interactions (for example, it appears from the behavior of the record LEDs that I successfully deleted all my cue points by entering Cue mode and pressing record a bunch of times), but I could not navigate out of this small stretch of tape, whether by FFW / RW in Nav mode, nor by trying to jump to cues (before and after I deleted them).

Rebooting the synth restored normal function, but my cues appear to actually still be intact.


Two observations:

  1. The way the Teletype on the left side of the rack moves around is so concerning

  2. I can’t get enough of the way the tape revs up and down when you start/stop


are you referring to the only instruction video we have??


for me the “brief bit” was ~250ms if the very beginning of the tape.

happened after clearing cues, then hitting play.

had to reboot to get it back to working.

happened twice, could not reproduce a third time


In general if you’re hearing that short piece of sound only (168ms to be exact) it means the SD card driver has frozen, and you’re just hearing what was left in RAM. The strange thing is I never see this with the unit I’ve been testing (and there’s been a lot of testing!!). Frozen SD driver also explains why editing of cues weren’t saved.

Monday morning I’m going to work through a bunch of different SD cards and see if it’s a result of differences between cards. I’d be very happy to start seeing these bugs, because it means I can measure & debug the actual reason for them, and then find a solution. It’s a strange life to be frustrated when things aren’t broken!