W/ Firmware Update (v1.2.1)


Sorry for the vague description. My W/ works pretty consistenly - so when something goes wrong I haven’t often been paying complete attention to the preceding problems.

The audio was also a very brief piece - so it’s sounds like it could also be the SD driver. I didn’t use the clear queue commands before it happened - if that helps to pinpoint anything :slight_smile:

The module still doesn’t respond when I reboot normally - would you recommend re-installing the firmware? I could also try re-booting into Izzy.


does starting up with the clear tape command help?


I had a similar issue with one of my two both before installing the first beta and after. In the end I tried swapping the two sd cards between them which solved the issue, I’ve not had any problems using either one since.


This is super intriguing.


I’ve got the newest version in both of my W/s. One seems to be working reasonably well. The other is still glitching out when left alone for 10 minutes or so with nothing plugged in except for the output.


in live mode with this getting a trigger and that getting voltage from cold mac (first output), i have been able to achieve very morphagene like tape delay effects and indeed loops playing in reverse with negative voltage (while monitoring the live input). the survey knob acts a lot like the varispeed knob where CW pitches and speeds up and CCW does the same in reverse.

it sounds really cool and is super fun but honestly the behavior seems so inconsistent and i kinda have no idea what is happening or what is even going wrong when it stops working. i also very often get the high pitch sad sound and have to reset my module while playing around in this mode…

Mannequins W/ (with)

@stripes this one belongs in the W/ Firmware Update (beta testers?!) thread, but love to know if you’re experiencing the above inconsistencies with the original firmware, or if this is with the current beta. No pressure to help us test, but just trying to ascertain whether it’s definitely not fixed in the current beta.


word! i’ll hop over there. i actually never tried doing this with the original firmware. maybe i’ll revert and check it out. every time i patch something up in w/ i understand a little bit better what the heck is going on, even if it’s a bug!


Beta4 posted up top.

This one is not about stability, but rather focuses on sound quality. Clicks on loop points have been greatly reduced. They can still be heard in some cases, and there is certainly some things not-quite-right about it, but I propose that it’s a great improvement and makes W/ much more capable in looping & delay contexts.

In testing these changes I’ve noticed there are many more aliasing artifacts while recording backward than forward. This need not be the case, and is likely a single line bug hiding somewhere.

Furthermore it feels to me that aliasing under 1x has gotten worse again. I’d be very happy to hear from folks if they think the same. Having a hard time isolating all the issues over here (many of them were already interacting!)


Onward, I hope to post another update tomorrow or thursday with more stability fixes, and a little sprinkling of usability fixes. Hoping that will get us to a release-candidate by weekend, but not holding my breath on that.


beta 4 definitely has muuuuch smoother performance for me. tried out the delay stuff in live mode as well as normal looping. clicks are almost entirely gone for me!

i’m also definitely hearing the aliasing grit more on reverse. as well it’s pretty intense when you increase the speed, but i can’t remember if that is worse than it was before.

i did get the overload noise and freeze once again when i was using a trigger into THIS while in live mode. i’m going to keep testing that. i just figured out how to get the tape loop delay thing working really smoothy and i am so in love with it… but i think while experimenting i was pushing the limits a bit before and maybe caused the module to freeze up from my own misuse?


I happened to have out patched to Clouds while updating and noticed that the lights on Clouds were moving so I listened—did you program the pretty little melody to play as the bootloader works?


It will be a different melody for each firmware :slight_smile:

These limits you speak of are the barriers I’d love to break down. If you can articulate what it is that feels like pushing too hard, we can work to ensure the module can handle it technically.

I’ll look into the THIS.LIVE behaviour to see if i can break it. Intuitively I don’t see a reason this should be problematic. Are you switching modes (ie. pressing ‘play’) while doing this?


wow, that’s beautiful.

So far, noticing a click happening at the end of a preexisting loop, but it went away when I moved the cue slightly.

Time to experiment with CV I guess! So far I’m noticing that changing speed with that Nav mode there is basically no aliasing when playing forwards at any speed for a pop song clip I recorded at 1x speed, but significant aliasing in reverse speeds slower (in magnitude :wink:) than -1x


yeah… i believe it happens when the trigger is fast and also when i switch back and forth between nav and live modes with cold mac into THAT, while also twisting the survey knob like mad because i love to make insane tape scrubbing sounds under whatever is going to IN and then switch back to looping delay :smiley:

edit: yep… doing that just got it to freeze again haha

edit edit: i’m button mashing the boss on your module but it’s just so fun and sounds SO GOOD


wow, I just tried Cue mode CV for the first time… it’s so good! SO GOOD

gonna try to copy @stripes’s patch to see if I can freeze mine

ETA tried this: Maths ch 4 eoc into this, first a cycling ch 1 into that and then ch 2 with manual wiggling into that, pressed play a bunch and then pressed all the buttons more or less randomly, but did not flick the toggle—no crash.

Then, suspecting that @stripes you meant that you set a loop while doing all of this, I tried flicking the toggle as well and indeed my unit is now unresponsive. No high-pitched sound though, that’s nice.

My LEDs are yellow over the toggle, white over loop, yellow over play, both over record and none over in.


A restart put me back to normal, but now it is my bedtime. I did get some nice “hand on record” speed changes before I crashed it!

Definitely gonna have to come back to Cue mode CV when I’m not trying to break things.


yep, loop going during my crashes as well. i sometimes get frozen with that same lighting configuration and no high pitch sound, and sometime with.


Just got the stuck in loop bug with the following:
updated to v 4 beta
have audio in and out to monitor
(worked fine for a while playing and recording backwards and forwards w/ w/type and cv into that)
in tt live mode and the short loop began. Turned off w/ loop but recorded loop is inescapable, inescapable


Tried to change tapes and w/ locked up with yellow light above switch and both lights above loop button on


@Galapagoose - update regarding my W/ being totally unresponsive, even with a power cycle, following a lock up with the new firmware.

I tried installing the beta 4 - and W/ was still doing nothing.
I then reverted to v1.0.1 - and W/ became responsive again. I played around with it a bit. And then reinstalled beta 4. As far as I can tell W/ is now functioning correctly

This makes me think that the beta has introduced a bug where the firmware can’t initialise properly when W/ is certain states. Sorry that I can’t offer any idea of what caused this state, if it happens again I’ll provide more deets.

(I really missed W/ when it wasn’t working)

Update: It’s happened again - seems to be a caused by switching to a certain one of my tapes. I’ll have more of a play later and see if I can get a reproducible series of steps.