W/ Firmware Update (v1.2.1)

Thanks, that often describes my issue, though I’ve experienced it when powering down with CV into That in NAV mode (tape moving). I haven’t tested powering down this way with the newest firmware yet.

@Galapagoose - Not sure if this will be entirely helpful, but the infinite short loop bug has been happening pretty consistently for me on the latest beta, even after starting with a cleared tape. Seems to happen every 3rd of 4th time I boot up the modular and start using w/ – happens pretty much immediately, actually. So far, I’ve observed the following (in LIVE mode specifically):

  1. With PLAY is engaged (forward-playback), I toggle down to insert a start point, and then the module goes into the short loop bug when I toggle up to close the loop. AFAIK, these loop points are being inserted into a blank part of the tape (no previous recordings or cues).
  2. Again, with PLAY engaged (forward-playback), the bug can occur when a previously recorded loop reaches its closing loop point.

I should also note that, as far as I can tell, I didn’t have anything plugged into either THIS or THAT in these instances. Let me know if you have any follow-up questions!


i can confirm this bug; it triggers the same way for me as soon as i toggle up to set the finish & loop marker.

this same bug is triggered when using the two-button record+loop method to set an immediate marker when starting play; as soon as i toggle up, the bug hits.

both methods were duplicated after a fresh power-up, using a completely blank tape even after following the “factory reset/wipe all” procedures, and nothing plugged into this/that.

1 Like

@Galapagoose same issues here as per @Olivier - this is the main issue I have right now and seems to have got more frequent on the last beta - as per @ioflow also

@ioflow & @mlogger
Do you see this every 3-4th boot too?

If it’s one of the times when it doesn’t go into the buggy behaviour, are you able to use the module normally? What I’m getting at is whether this is linked to the startup procedure, or if it’s something more general. Do you ever see this behaviour after having successfully used the module for a while?

Did any of you have record engaged? Does it matter whether or not?

The last couple of times it happened, record was not engaged. The behavior manifests itself most consistently at startup with the newest beta, but I feel like it’s happened also mid-session (probably more often with previous betas or the original release firmware). Recently, though, if the module boots without issue, I’ve had long, productive and error-free sessions.

Hope some of this actionable/helpful!

1 Like

Yes - the most consistent times are either at boot and especially if the module is left for 10 or 15 minutes (no CV cable in). It seems to go into a sleep mode after a certain amount of time, when i come back its in perma loop when i start to record stuff again. Clearing cues don’t kill it either, i have to reboot and clean the tape.

1 Like

just rebooting has been enough for me when I’ve gotten SD card driver crashes, I will say. But I most often get them when I’ve left the module alone for a while; I may have gotten one or two just after powering up, but I don’t remember.

yes, its when the module is left alone i get them most

1 Like

I’ll chime in to add that I get that issue pretty consistently after leaving it sit for about 10 to 15 minutes with nothing plugged in except for the output.

1 Like

Installed the latest firmware on Friday, updating from the original firmware. Have played with w/ for a few hours at a time, several times, since installing.

Much, much smoother sailing compared to the original firmware.

I have not been having the ‘stuck in a short loop’ problem at all so far. Setting loops with down then up has been working out. Have not tried down+r.

I have had the module crash after much overdubbing of loops, and got the dreaded glitch noise after attempting to change tapes. I was in live mode with play engaged, switched to global (monitoring input all along), tried to switch to tape 2, glitch sound immediately blared out, rebooted and was back on previous tape.

Also, have had the module crash after leaving it idle (idle meaning receiving input, but play not engaged, record not engaged, nothing to THIS or THAT) after approx. 20-25 mins or so. Has happened a few times (though not comparable to the # of reboots required on the og firmware).

One of these reboots, after some heavy cue setting and overdubbing, yielded a completely unresponsive w/. No lights, no nothing. Rebooting w/ r + down and clearing everything out brought w/ back to life.

If there are any specific action combos it would be helpful to repeatedly try out, I’d be happy to give it a whirl.


Hey there! I had some freezing issues with the firmware my W/ came with and the beta fixed those issues! Bit of bad news: now it distorts when I layer two or more sounds.

Edit: after playing more with the beta firmware, I noticed It got stuck in a loop during regular playback. Tried switching to a new tape and the module froze. This happened after it had been left on for about an hour and a half.Has this happened to anyone else?
Thank you for your hard work and amazing modules! <3

1 Like

One thing I was able to do without trouble on this latest firmware was load, and then via a combination of rewinding and cue jumping, get to the beginning of each tape, listening a little bit here and there. It let me do this for all the tapes in sequence without a reboot. Play was not engaged when i accessed global mode between each tape. Was never able to do this on the original firmware, so finding this very exciting :slight_smile:

1 Like

I can’t be the only one waiting for some movement in this thread…so here it is. Though I’d also rather see Galapagoose doing the posting. This is the longest 16 days between beta versions ever as we wait for an update.


Was testing and breaking the beta last night - no notes to report sorry but I am interested for some information and discussion on expected behaviour of w/Type when CV is applied to This and That. I was finding inconsistent behaviour and a couple of the reported bugs. With so much going on its hard to pinpoint what was happening at any given time but I’d like to really test it out with the new firmware release.


I identified a problem that I was having with W/. After starting W/ holding the joystick down and record to clear all tapes I would get inconsistent behavior if I could get W/ to really work at all. Finally I power cycled it immediately after clearing tapes and now rewind and play work consistently so I can start to move forward to more testing.

Playing a tape backwards driven by Cold Mac into That is when I’m getting the worse aliasing of the signal. Forward sounds brilliant.

1 Like

New update up top. Afraid it’s not leaps and bounds since the last. Efforts have been focused on the saving & loading of metadata (cue points, current tape & cuepoint, last recorded location). This means less sd-card wear, but better handling of powerdowns while recording is engaged.

Additionally tape-switching has had some changes, so do make a note if you see freezes or hangs while switching tapes.

Lastly, a complete list of our open issues for 1.1 are posted up top. I believe it covers all the issues mentioned throughout this thread (even if the descriptions aren’t immediately obvious)


i get bumped back to the beginning of the tape every time, so hopefully this will help! thanks!

Beta5: Cleared all tapes after install. Recorded short 10 second audio of clean undulating Telharmonic sound.

Plays perfectly. Let unit stand for 15 minutes. No lock up and audio plays again, and again, and again.

Let stand for 10 minutes and playback has regular tick sounds where there were none.

Restart unit and audio plays clean again. I can rewind (aliasing noise during rewind not just reverse playback, but clean fast forward) and play. Fast forward a bit and play, rewind and play. Everything consistent so far.

Leave alone for 15 minutes and this time it plays fine no clicks or ticks. Then I enter slow forward play followed by faster forward and the tick returns. Will test more tonight and over the weekend.