Windows 10 - grid 128 stopped working

hey Sam! good to see you here (sorry about win10)

first step might be to just reinstall serialosc

after that check for com port enumeration

then we can go from there!

Apologies for the delayed response, I just started the first leg of a Sonic Pi tour - currently in Germany and then headed to the States tomorrow :slight_smile:

@alanza I’m a bit of a weirdo and not using Max at all. I’m using a bit of software called Sonic Pi that works directly with the raw OSC stream. The issue that I’m currently having is that this OSC stream is no longer making it to Sonic Pi on my Windows machine (but it does on my Mac). The problem is therefore not with the hardware, but likely with serialosc or its interaction with Windows (firewalls etc.)

@tehn Hi :slight_smile: Reinstalling serialosc was the first thing I tried but no ball. Do you know how to enumerate the ports on Windows? Also do you know if it’s possible to just cat the raw serial byte screen to disk so I can verify that the FTDI drivers are working?

I also read that Microsoft totally pulled this latest release of Windows (1809) as it was deleting people’s files. It struck me that perhaps Windows has deleted the serialosc config so it’s no longer sending to port 4559 on localhost, I’ll check that next time I fire the Windows machine up (today I’m delivering kids workshops all day :slight_smile:)

@samaaron please try this build of serialosc:

Due to windows default way of handling of UDP packets (serialosc will receive ICMP errors to the UDP port if it fails to send data to a given port and the IO could be blocked afterwards), using raw osc with serialosc can be problematic. The above build fixes that.

1 Like

Hi all, I have a similar issue with my grayscale 64. I first installed the serialosc server from but it would not recognize my monome in M4L Terns-Polygome. Well it did once and then after a minute or two the monome visual feedback froze though midi notes were still being played. It then went on to totally freeze my laptop. I then installed this 1.4.1b-pre version of the server. It worked ok for a while though it saw two or three instances of the monome device in the Terns-Polygome drop-down menu. This time I could play for quite a while with no problem. I tried M4L Terns-Flin with no success though. I later quit Ableton, rebooted the computer, opened Ableton again, tried M4L Terns-Polygome, one instance of the monome was now seen in the drop down menu but no visual feedback on the monome or midi notes being played… I’m lost here. It used to work fine on Win7 but not now. Is there a fix? Thanks for your help.

Any chance you’d have a solution for me?

Try the 1.4.2pre version in this thread: Arc2 and 128 Connectivity Issues on Windows

Ok, thanks a lot. But I did try after uninstalling the former version. Terms M4L Polygome can see the Monome but I get no midi in and no visual feedback whatsoever… I’m lost here.

can you test with Max and the monome package as described in the docs?

want to make sure it’s not an installation issue first, so we can confirm serialosc/etc is working.

Hi I tried with Max and Monome Sum. I get the same result. The Monome can be seen by the app, but that is all, no signal, no visual feedback. I also have to run the serialosc server manually and I get this message in it : [!] running as a non-service
serialosc [m64-0928]: connected, server running on port 16997

I dunno what that means.

this message means that serialosc successfully started the device process, so you have it working. do you also have it running in system services?

Yes also running in system services… Still the same issue.

This might actually be the problem. You should stop the service before running serialosc manually. Please try this and let me know if that helps.

I’m sorry but it doesn"t make a difference… I feel so dumb really. It used to work in Win7

Hmm, so when starting serialosc manually, do you see the dialog asking if network access should be allowed? It should appear twice (and both times you should allow the access).

Hi, here’s what I did. I uninstalled VCP FTDI drivers as it doesn’t seem to be a necessity anymore from what I saw in the setup instructions on I uninstalled serialosc and reinstalled the version on I still get the same thing… Monome seen but nothing else. And no I don’t get any dialog asking about network access. I tried running the monome with Kaspersky security off but no change.

Once I uninstalled serialosc version from, reinstalled the pre version but no change. I’m sorry to bother you guys with this. But I love my grayscale64. And it’s been months I can’t use it anymore. Worked seamlessly in win7

That’s strange, can you also check windows firewall settings to make sure that serialosc and serialosc-device are whitelisted?

Well. My laptop is using Kaspersky Endpoint Security with a company strategy I don’t have access to. I guess that’s where the problem comes. I had a look in Kaspersky and it says that serialosc.exe has got minor restrictions. I will go ask my network administrator to try and sort this out. But shouldn’t it work when i disable every possible firewall - Kaspersky and Windows Defender - and I disconnect from wifi and lan?

there can’t be serialosc.exe. serialosc ships with 3 executable binaries:

  • serialoscd.exe
  • serialosc-detector.exe
  • serialosc-device.exe

the main daemon (serialoscd) and the device controller (serialosc-device.exe) should be allowed to listen to network, even when you’re disconnected from a physical network, because the apps communicate with serialosc via network sockets on the local machine.

in your case, it looks like the main daemon is working well, because you see the device in max, but there’s an issue with the device-specific process (serialosc-device), which might happen because of the access restrictions.

Yes but shouldn’t it work when I disable my firewal ?