Windows 10 grid/arc problem 64 bit

Hallo …,
I have a grid 128 and the newest arc model. On Mac everything is fine, but when working with Windows 10 64 bit, I have the strange effect that only one out of 10 times max 7 detects both machines. Most often I can use one or the other. Even rebooting doesn´t give me satisfying results.

=> Anyone experienced something like that and knows how can I solve it.

best regards

no one, did I miss something essential ?

No, I’ve also been having issues with Windows 10 and Arc. I can usually get my Grid to connect, but never my Arc. Both connect to my Macbook 100% of the time.

I think that this is a critical issue, especially with Apple’s fumble yesterday. I think more people are looking at Windows as a serious platform for music. My primary computer is Windows, so this is especially frustrating for me.

I’ve included my reports and experiments here:

@trickyfleming that is good to know. My grid connects quite often, but as you said, the arc is a different story, hardly never connecting. I thought that somebody might eventually have coded a max patch that could refresh the controller request routine more often.

I also would welcome a tendency towards different computer platforms than apple, I have got the impression that these guys aren’t intrested anymore in musicians.

there is a known possible issue with new arcs and connection issues, regarding the first “batch” that was shipped out, primarily to pre-orders. e-mail info@monome.org if this is the case for you.

serialosc needs to be more thoroughly tested against windows 10. a new version hasn’t been compiled since windows 10 came out (a year ago, i understand). i’ll investigate this in the coming weeks.

1 Like

Thank you so much tehn, please keep us posted!

If I wanted to try to compile serialosc myself, is this repo up to date?

Hoo boy. Building this is no fun.

Clone Serialosc. Ran waf. “Run waf configure”. Okay.

Run waf configure. “libmonome: not found. configuration failed.” Okay.

Clone libmonome. Run waf configure. “liblo not found. configuration failed.” Okay.

“Liblo supports Windows. Kind of I guess. You can opt to build it without pthreads, but then it doesn’t work much. So you should probably do that.” (http://liblo.sourceforge.net/README-platforms.html)

Having worked with Windows pthread compatibility libraries before, I’m going to run for the hills on this one.

1 Like

yeah that sounds like my worst nightmare.

recent war story: i was working on a complicated windows game / hardware / networked / machine vision thing. waaay late in the project someone wants OSC stuck on there. (like 3 days before deadline.) i’m not a windows guy so i’d think liblo would be the obvious tool. but it was such a mess that i ended up rolling my own OSC server/client with boost threads and oscpack.

if my life depended on building libmonome/serialosc on windows, i’d have to try msys2 and pthreads-win32… guess that’s what you’re already trying.

but clearly someone on here knows how it’s done.

1 Like

Yeah, I’ve tried my best to avoid liblo since my first iOS project.

Similar war story:

I was writing a chaotic synth as part of my Masters, and I wanted to add in OSC. So, I add in liblo. One of my other department friends points out that liblo’s license and iOS were mutually incompatible (at least, at the time). I write to the liblo mailing list about this, and I’m sent back a link to a thread with dozens of posts where the team is battling over this license in a most stereotypical, open-source way. You have the pragmatists (“It’s against the current license, but not supporting iOS is terrible for our library”) vs. the purists (“Apple is Satan, and iOS is the most anti-open-source platform ever”).

So I e-mail Ross Bencina, ask about oscpack and iOS, and get an e-mail back the same day that pretty much is like “Yeah, mate, that’s fine”. Done.

I think the following things should be done to help serialosc and libmonome moving forward:

  1. Short-term. IMPROVE DOCUMENTATION. This part is terrible. I had never seen waf before, so I had to Google that and figure out what was going on there. I’m not saying remove it, just add step-by-step instructions for each platform. That includes pulling and updating submodules, and where to place library binaries after they’re built. I gave up at the liblo and pthreads step because I knew that even if I managed to run through that gauntlet and get it built, I would still be at sea with where everything would go. Perhaps pre-built libraries could be included in the repo in the correct spots?

  2. Long-term. Rip out the UNIX-heavy libraries (liblo + pthreads) and replace them with a more viable cross-platform solution that doesn’t make Windows a second-class citizen.

I’m having some pretty serious issues on Windows 10 also. I use 2014 walnut arc and grid with Max 7 64 bit.

Sometimes, I connect both devices and everything works fine. Other times, the max serialosc object does not recognize the devices. And whether the serialosc object recognizes the devices or not seems completely random. Sometimes if a M4L patch doesn’t see the grid I would open a new patch in max an create a new instance of a serialosc object, and then the grid shows up on both places. Othertimes this trick doesn’t work. Also, it seems that the likelihood that Max recognizes a monome is much higher if I only connect the grid; If i connect both the grid and arc, 95% of the time neither shows up.

I have uninstalled and reinstalled all the drivers/servers/libraries… does not help. I have tried using every previous version of a max serialosc object, and the performance seems equally spotty on all of them. I have verified that in the task mannager the serialosc server is running smoothly, with a separate instance of the server popping up for both the arc and the grid - so I don’t have the typical Win 10 problem where the server fails to start automatically. At this point I don’t know what to do.

Windows 7 performance was not 100% either, but that is irrelevant at this point.

The only time the grid works with a 100% reliability is when I have it hooked up to an Arduino Due, outputting CV to my modular. And I’m all happy with that, so its unlikely I’ll be parting with the monomes anytime soon. However recently I have used the grid and arc for running audio/video cues for theater. And it is dedinitely infuriating to have to spend 20 minutes at the beginning of a tech rehearsal rebooting windows and restarting max, trying to get the monome devices to show up. And frankly until this nonsense is sorted out I’m just not comfortable enough to use my monomes for any live performance. Which makes me feel pretty shortchanged.

So, a message to the monome team: Could we PLEASE get the Win 10 drivers to work! I’ve spent a very pretty penny on these toys, and it just baffles me how very poor the driver support is. I’m starting to feel that with the monomes its all flash and no substance.

@silverapple I experienced problems with the newest version of arc and win10. The workaround for me as @tehn suggested is, connecting the arc to a powered hub. Now I can work quite stable with windows and monomes. I love these devices and I am glad I can work either on Mac OS or on Win10.

Thanks, @mheton! I’ll give a hub a go, see what happens. However the osc server does always register and instantiate the devices, so I’d think the problem is not with the usb network, but with the max serialosc library. Maybe I’m missing something.

try this:

search your win10 system for “serialosc.maxpat” and locate the one that’s inside Max 7 (it’s in a BEAP folder).

replace serialosc.maxpat and serialosc.js with those attached here. you can now click “none” to refresh the device menu. let me know if this works for you.

serialosc.js (1.8 KB)
serialosc.maxpat (24.6 KB)

I’m getting a “Failed - server problem” when saving serialosc.js on Chrome. The maxpat saves fine.

I get the same error. But I assume, these are the same files as in the serialosc.maxpat folder on github.

here it is zipped.

serialosc-161120.zip (3.4 KB)

yes, same as github, but these are not the same as those in the Max 7 install as they have not been merged

@tehn, thank you for a quick reply. Unfortunately, still the same behavior persists. I’ll monitor it further.

ok-- clicking “none” does not refresh the menu?

what fixes the issue?

  • reload patch?
  • replug device?
  • reboot?