WW+MP+ES in VCVRack


#41

Nice anthurium…


#42

Good eye!

@Dewb, I’m having two issues when trying to compile the Teletype branch on Mac.

I’m getting a compiler error:

teletype/module/flash.c:27:35: error: argument to 'section' attribute is not valid for this target: mach-o section specifier requires a
      segment and section separated by a comma
static __attribute__((__section__(".flash_nvram"))) nvram_data_t f;
                                  ^
1 error generated.
make[1]: *** [../build/firmware/teletype/module/flash.c.o] Error 1
make: *** [firmwares] Error 2

Also, git submodule is complaining about the Teletype repo:

~/C/R/p/monome-rack (teletype) $ git submodule update --init --recursive
error: Server does not allow request for unadvertised object f90ea318446d932b64c5564063d4fe61a571977c
Fetched in submodule path 'firmware/teletype', but it did not contain f90ea318446d932b64c5564063d4fe61a571977c. Direct fetching of that commit failed.

I tested out manually checking out the master branch and latest commit in the Teletype repo, but the compiler error is still occurring.

I also already tried doing a make clean. Is something up with my toolchain? I recently updated XCode to 9.2.


#43

You need to add an #ifdef like Dewb did above for white whale:

On line 27 of teletype/module/flash.c:

static __attribute__((__section__(".flash_nvram"))) nvram_data_t f;

becomes:

#ifdef TARGET
static __attribute__((__section__(".flash_nvram"))) nvram_data_t f;
#else
nvram_data_t f;
#endif

#44

Thanks!

I see what happened now. @Dewb, the master branch points to the monome Teletype repo, while the teletype branch correctly points to your Teletype repo.

I did a git submodule init on the master branch, so it kept the old submodule remote address.


#45

Ah, yeah, sorry you had to deal with that. Submodules are weird and messy, but the alternatives have their own problems. I’ll either delete or update the submodule reference in the master branch so switching will be less complicated.

EDIT: You can generally recover from submodule branch-changing weirdness with a sync followed by an update:

$ git submodule sync
$ git submodule update --init --recursive

Having said that, there’s likely not much reason to build the TT branch, unless you want to start working on HID frame simulation. Right now I’m focused on getting the existing stuff releasable before I start chewing on the TT problems again. Release checklist/planning is happening here: https://github.com/Dewb/monome-rack/projects/1


#46

Awesome! Thanks for the heads up. I saw that you just added Meadowphysics as well… Can’t wait to try that out later tonight!


#47

Also, @Dewb, let me know if I can help with the SVG side of things. I wouldn’t mind taking a stab at the panels and knobs. I’ve been working in Illustrator a bunch lately because of HetrickCV.


#48

Yup, added Meadowphysics and Earthsea today. And SVG panels and knobs!


#49

Just want to add my appreciation for the efforts here. The talent in this community is staggering at times.


#50

am i the only one having problems installing (building) VCV? first problem is i can’t install xcode…


#51

Installing xcode is an important first step. I believe you can find it in the Apple app store.


#52

I would totally welcome help on the SVG graphics! They’re mostly in place but there are a few details still bugging me, like the 1 is totally incorrect – Gill Sans is close, but it’s not the right typeface.

I’m also on the fence about what to do with the screws. The default screw graphics in VCV Rack don’t really look right with the hole placement on the trilogy modules, and I feel like it’s taking the skeumorphism a little too far. So I took them out in the latest version. On the other hand, a smaller, subtler screw graphic and subtle oval hole might look good, and balance out the module names a little better. But a nonstandard screw graphic might look strange racked with other modules.


#53

The monome modules use Core Humanist Sans Italic.


#54

I like them without the screws. Screw the screws!


#55

does all this mean there’s a chance we’ll see kria coming over to the computer soon?


#56

Yep! Ansible and Orca are on his Project Board.


#57

hot dog! (´「^o^)「 \(゚ー゚\)


#58

Yeah, as @trickyflemming said, Ansible is in the long-long-term plan after Teletype/AT32UC3C0512C support and arc support is already done.

But now I’m thinking that Kria for WW might be worth doing a little sooner. (I ran Kria on my WW for a while but I had to go back to WW, because, well, WW is awesome all by itself, but also because when I play with Nick in hybriddecliners.com I need external clock sync.) I totally missed that Kria standalone has external sync now! Awesome.

It took me just a few hours to do Meadowphysics, and even less for Earthsea as the number of new problems / bugs in my hardware translation layer drop, so hopefully the effort required for alt firmwares will be low.


#59

Aha, thanks! I knew I should have asked first before trying with Gill. I vaguely recalled it coming up in the telex thread but I couldn’t find the magic search term.


#60

This week I’ve been working on more accurately simulating the FTDI bus and allowing the modules to do device recognition.

So in addition to the original virtual varibright 128, there’s now a virtual varibright 64, and virtual monobright 128 and 64 for testing purposes, or if you just like the mono look. The virtual mono 64 simulates a 40h device and the mono 128 a series device.

The upshot of all that is that hopefully all the hardware versions of above should work, too. I only have a varibright to test with, so if people with series and 40h devices could give it a spin and let me know if they work, I’d appreciate it!

Also, fair warning, with the new more complex serial simulation there are likely a number of new bugs. Things seem to work pretty well for the most part, but please expect occasional weirdness (and report it on github if you see any.)