WW/MP/ES teletype updates

updated firmwares for ww/mp/es for teletype communication:



header must be soldered on. then ribbon cable connected, aligning GND with red.

will get this in the docs.

2 Likes

Just to be clear: in addition to the ribbon connecting all four modules, each of the trilogy modules also needs to be individually plugged into the case rail. Correct?

Yes, exactly.

The ribbon cable is entirely for communication so one can use the ‘II’ messages in Teletype to control these modules. All modules still need the normal power connection.

if anybody in Vancouver, BC can help with soldering that’d be very much appreciated - in exchange i can offer to update your firmware. or buy you a beer!

Just finished this, its a really basic job, no probs encountered. Especially after building the grid kit!

I can help out, should be super quick to do.

1 Like

just to make sure - this is the cable I got, I don’t see anything that can be detached and soldered - is there a separate part that I need?

The thing that might need to be solderd are the three-pronged headers that would go on the back of the trilogy modules. The cable you have, would plug into them.
As far as I understand the newer trilogy modules shipped with the headers already soldered, so you should check and see if they are there. If not, then you will need these:

1 Like

interesting, I’d thought it was going to use the same 6-pin breakout for the ftdi, this is way easier. Through-board soldering is a piece of cake - for anyone with no previous experience it’s a good starter: an inexpensive iron, some flux-containing solder, a youtube video, a little practice on some wire, and you’d be good to go.

I see two of the three modules shown have the ftdi header soldered on (for debugging?) Getting ready to do this with my new MP, nice to see it what it looks like done. (Might be nice to include a pic of the complete physical debug setup with the docs for development?) would these headers not also be a way for the modules to communicate?

It looks like you could snap a 6-pin header in half to get those 3-pin headers? I thought I read somewhere these were going to come sticking out of the cable plugs for those of us with older trilogy modules to mount.

Is there also only enough cable length such that the TT has to be to the right of the trilogy set? It doesn’t look from the pic that it would reach across the other way. Not that rack position is important to me, it just seems uncharacteristically limiting. I guess there’s nothing stopping me from buying/making/extending a longer ribbon cable.

It looks pretty badass to see them all hooked up together. It’s like a Voltron of Monome modules. Only the legs (i.e. Walk) are missing from these pictures.

you were in the early batch and we forgot your headers! we’ll get some out to you-- apologies for the trouble.

1 Like

@laborcamp @tehn thanks guys!

did check my ww by the way and yeah, it doesn’t have a header.

i was preparing to update my ww and es. necessary cable just arrived. but i do not use tt, nor planning to as it stands (no room yet). what are the best firmwares for current versions of trilogy modules if tt is not in the use/patch picture?

Just soldered the headers on the trilogy.
The whole operation took maybe 10 min. Super easy.

Installed the three latest firmware updates on the modules.

Connected all three to teletype.
Let’s explore!
:smile:

1 Like

So, did anyone here try controlling the trilogy modules through the internal remote functions from teletype? I am curious to hear if/how you guys went about it…

Anybody tried the factory scenes for earthsea or meadowphysics?

Can anyone please at least confirm that they got this working properly?
Thank you!

i didn’t have the time to really test it yet but a quick test by manually selecting a pattern on WW from TT worked for me.

Thank you for responding!
I am asking, because, as you might suspect, things are not quite right in my setup.
I have experienced freezes, weird behavior etc. I have only really tried having teletype communicating with earthsea. Earthsea now exhibits bizarre behavior, even after I disconnecte it from teletype. All this after updating to the most recent firmware recommended for the teletype implementation… :frowning:

worth mentioning - i only have WW connected, no MP or ES.

Did you notice a slightly sluggish behavior on WW with the new firmware and/or since linking to teletype?
I did not really test WW, but observed noticible lag in responsiveness when selecting patterns (row 3)…
again, I only noticed this after installing the new firmware.

sorry - can’t really say as it was just a quick test to confirm the link working. i’m away for a few days but will test once i’m back (and will be working on updating Orca so that it can react to TT remote commands).